View Issue Details

IDProjectCategoryView StatusLast Update
0026449LazarusOtherpublic2015-12-03 17:20
ReporterThomas L. BabielAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSXP/wind 7OS Version32 bit
Product Version1.2.5 (SVN)Product BuildLazarus 1.3/fpc 2.7.1 32 bit 
Target Version1.6Fixed in Version1.6 
Summary0026449: valuelisteditor and umlauts
DescriptionUnder Windows 7/XP 32-Bit the attached program fails to restore umlauts von xmlpropstorage to the valuelisteditor.

The same code works ok with stringgrids or edit-fields.

Under Linux (Debian 64 bit with Lazarus 1.3/fpc 2.7.1 54 bit) and on Windows 8 64 bit everything works finde.
Steps To ReproduceCompile the attached sourcecode. Fill the directory-edit with a path/filename with umlauts, close the programm, so that xmlpropstorage saves the text with umlauts. Start the programm: everything works, but in the valuelisteditor the umlaut becomes "?'
TagsNo tags attached.
Fixed in Revisionr45782, r50568
LazTarget1.6
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0026453 closedJuha Manninen Memo.Lines and umlauts 
related to 0028406 closedBart Broersma possible Patch -> bug in TFileSearcher -> umlauts not found 
child of 0028857 closedBart Broersma Implicit Codepage Conversion meta issue 

Activities

Thomas L. Babiel

2014-07-04 14:59

reporter  

umlauttest1.zip (130,521 bytes)

Mike Thompson

2014-07-04 15:20

developer   ~0076064

Last edited: 2014-07-04 15:21

View 3 revisions

I've tested this under Lazarus 1.2.4, this works on Windows 7.
I've confirmed this fails under Win 7/Lazarus Trunk....

Bart Broersma

2014-07-05 00:24

developer   ~0076067

Last edited: 2014-07-05 00:36

View 3 revisions

Does your Windows codepage support the u+umlaut?
What happens if you do:
Edit2.Text := 'Umlaut' + Chr(32) + XMLPropStorage1.ReadString('Hi', 'nix');?
or
Edit2.Text := 'Umlaut' + vle.Strings.NameValueSeparator + XMLPropStorage1.ReadString('Hi', 'nix');?

(Maybe the concatenation somehow screws up the string's encoding?)

Jesus Reyes

2014-07-05 06:32

developer   ~0076069

Yes, concat was the problem. Please test.

Mike Thompson

2014-07-05 07:53

developer   ~0076070

Now works under Win 7/Lazarus trunk.

Bart Broersma

2014-07-05 22:55

developer   ~0076092

Maybe comment the code on why this was done?

Bart Broersma

2015-11-29 14:30

developer   ~0087673

I'm unhappywith the current fix (using Insert into a Dummy string).
We need a proper fix.
Util then I leave this report open.

Ondrej Pokorny

2015-11-29 16:11

reporter   ~0087674

Is the fix needed at all?
I tested Laz 1.5 trunk + FPC 3.1.1 trunk, reverted r45782 and I cannot reproduce the issue on Windows 7 32bit.
Maybe the concat has been fixed already?

>> I'm unhappywith the current fix (using Insert into a Dummy string).
>> We need a proper fix.

Yes, r45782 is not a fix at all...

Ondrej Pokorny

2015-11-30 12:59

reporter   ~0087689

I tested Windows XP 32bit, Lazarus 1.5 trunk + FPC 3.0.0, reverted r45782 and:
I cannot reproduce the bug anymore.

The concat seems to be fixed already.

I propose to revert r45782 in trunk.

Bart Broersma

2015-11-30 13:31

developer   ~0087691

I will do so (when I have time), and leave in some comments.
I'll leave this ticket open for a while though.

Bart Broersma

2015-12-02 13:55

developer   ~0087750

Reverted the changes of r45782 in r50568.

Issue History

Date Modified Username Field Change
2014-07-04 14:59 Thomas L. Babiel New Issue
2014-07-04 14:59 Thomas L. Babiel File Added: umlauttest1.zip
2014-07-04 15:20 Mike Thompson Note Added: 0076064
2014-07-04 15:20 Mike Thompson Note Edited: 0076064 View Revisions
2014-07-04 15:21 Mike Thompson Note Edited: 0076064 View Revisions
2014-07-05 00:24 Bart Broersma Note Added: 0076067
2014-07-05 00:33 Bart Broersma Note Edited: 0076067 View Revisions
2014-07-05 00:33 Bart Broersma LazTarget => -
2014-07-05 00:33 Bart Broersma Status new => feedback
2014-07-05 00:36 Bart Broersma Note Edited: 0076067 View Revisions
2014-07-05 06:30 Jesus Reyes Assigned To => Jesus Reyes
2014-07-05 06:30 Jesus Reyes Status feedback => assigned
2014-07-05 06:32 Jesus Reyes Fixed in Revision => 45782
2014-07-05 06:32 Jesus Reyes LazTarget - => 1.4
2014-07-05 06:32 Jesus Reyes Note Added: 0076069
2014-07-05 06:32 Jesus Reyes Status assigned => resolved
2014-07-05 06:32 Jesus Reyes Fixed in Version => 1.3 (SVN)
2014-07-05 06:32 Jesus Reyes Resolution open => fixed
2014-07-05 06:32 Jesus Reyes Target Version => 1.4
2014-07-05 07:53 Mike Thompson Note Added: 0076070
2014-07-05 14:45 Juha Manninen Relationship added related to 0026453
2014-07-05 22:55 Bart Broersma Note Added: 0076092
2015-09-29 11:48 Juha Manninen Relationship added related to 0028406
2015-10-14 23:39 Bart Broersma Relationship added child of 0028857
2015-11-29 14:30 Bart Broersma LazTarget 1.4 => 1.6
2015-11-29 14:30 Bart Broersma Assigned To Jesus Reyes => Bart Broersma
2015-11-29 14:30 Bart Broersma Note Added: 0087673
2015-11-29 14:30 Bart Broersma Status resolved => assigned
2015-11-29 14:30 Bart Broersma Resolution fixed => reopened
2015-11-29 14:30 Bart Broersma Target Version 1.4 => 1.6
2015-11-29 16:11 Ondrej Pokorny Note Added: 0087674
2015-11-30 12:59 Ondrej Pokorny Note Added: 0087689
2015-11-30 13:31 Bart Broersma Note Added: 0087691
2015-12-02 13:55 Bart Broersma Fixed in Revision 45782 => r45782, r50568
2015-12-02 13:55 Bart Broersma Note Added: 0087750
2015-12-02 13:55 Bart Broersma Status assigned => resolved
2015-12-02 13:55 Bart Broersma Fixed in Version 1.3 (SVN) => 1.6
2015-12-02 13:55 Bart Broersma Resolution reopened => fixed