View Issue Details

IDProjectCategoryView StatusLast Update
0026491LazarusWidgetsetpublic2014-07-18 18:03
ReporterVojtech Cihak Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformamd64OSLinux 
Product Version1.3 (SVN) 
Summary0026491: [Qt] Frame3d is not transparent
DescriptionFrame3d is not transparent when FrameWidth = 1 and Clipping is used.

This is reincarnation of issue 24445. Now are affected both Canvas.Frame3d and LCLIntf.Frame3d but only with Clipping.

Works well for FrameWidth>1 or on GTK2.
Steps To ReproduceRun demo. Rectangles shoud be transparent (empty).
Additional InformationLazarus 1.3 r45856M FPC 2.7.1 x86_64-linux-qt

Related to: http://bugs.freepascal.org/view.php?id=24445
TagsNo tags attached.
Fixed in Revision45913
LazTarget-
WidgetsetQT
Attached Files

Relationships

related to 0024445 closedZeljan Rikalo LCLIntf.Frame3D issue 

Activities

Vojtech Cihak

2014-07-16 15:01

reporter  

Frame_3D.zip (5,940 bytes)

Zeljan Rikalo

2014-07-18 11:35

developer   ~0076248

hm..."Now are affected both Canvas.Frame3d and LCLIntf.Frame3d but only with Clipping", it is not transparent with or without clipping.

Vojtech Cihak

2014-07-18 12:34

reporter   ~0076249

Really. Then it is even more strange than I thought, because the demo from 24445 works well.

Zeljan Rikalo

2014-07-18 14:47

developer   ~0076251

Problem is with r41475 and regular TCustomPanel.

Zeljan Rikalo

2014-07-18 16:31

developer   ~0076253

Please test and close if ok.

Vojtech Cihak

2014-07-18 18:03

reporter   ~0076254

I tested with r.45913. Thanks.

Issue History

Date Modified Username Field Change
2014-07-16 15:01 Vojtech Cihak New Issue
2014-07-16 15:01 Vojtech Cihak File Added: Frame_3D.zip
2014-07-16 16:30 Zeljan Rikalo Assigned To => Zeljan Rikalo
2014-07-16 16:30 Zeljan Rikalo Status new => assigned
2014-07-18 11:28 Zeljan Rikalo Relationship added related to 0024445
2014-07-18 11:35 Zeljan Rikalo Note Added: 0076248
2014-07-18 12:34 Vojtech Cihak Note Added: 0076249
2014-07-18 14:47 Zeljan Rikalo Note Added: 0076251
2014-07-18 16:31 Zeljan Rikalo Fixed in Revision => 45913
2014-07-18 16:31 Zeljan Rikalo LazTarget => -
2014-07-18 16:31 Zeljan Rikalo Note Added: 0076253
2014-07-18 16:31 Zeljan Rikalo Status assigned => resolved
2014-07-18 16:31 Zeljan Rikalo Resolution open => fixed
2014-07-18 18:03 Vojtech Cihak Note Added: 0076254
2014-07-18 18:03 Vojtech Cihak Status resolved => closed