View Issue Details

IDProjectCategoryView StatusLast Update
0026506LazarusLazReportpublic2014-09-29 15:58
ReporterPéter GáborAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionProduct Build 
Target Version1.4Fixed in Version1.3 (SVN) 
Summary0026506: Report Designer: Undo raises "List index (-1) out of bounds"
DescriptionReport Designer: Undo raises "List index (-1) out of bounds" in some circumstances.
To see it: place a combination of some rectangles/lines and click "Undo" icon on the standard tool bar twice or more... maybe not at first try.

Once another exception occurred (while trying to reproduce the bug): "Access violation"
TagsNo tags attached.
Fixed in Revision46137
LazTarget1.4
Widgetset
Attached Files

Activities

Reinier Olislagers

2014-07-19 17:11

developer   ~0076273

What Lazarus version? What revision? What OS?

Péter Gábor

2014-07-19 17:27

reporter   ~0076274

Oops, sorry!
Linux + XFCE, x86 (32bit), SVN 1.3 (r45928 = now)

Péter Gábor

2014-07-20 17:34

reporter   ~0076292

Similar: 0026504

Péter Gábor

2014-09-09 15:32

reporter   ~0077000

Last edited: 2014-09-09 15:44

View 3 revisions

Undo action does not update the display correctly: visual markers remain on the page(s).
Maybe this should be another bug-report, because this issue seems to be older than this fix.

Jesus Reyes

2014-09-09 18:42

developer   ~0077007

Last edited: 2014-09-09 18:43

View 2 revisions

Yes, please open a new bug report. Only reopen a bug report if the fix didn't work.
If the issue is fixed, please close this bug report.

Issue History

Date Modified Username Field Change
2014-07-19 13:11 Péter Gábor New Issue
2014-07-19 17:11 Reinier Olislagers Note Added: 0076273
2014-07-19 17:27 Péter Gábor Note Added: 0076274
2014-07-20 17:34 Péter Gábor Note Added: 0076292
2014-07-21 05:50 Jesus Reyes Assigned To => Jesus Reyes
2014-07-21 05:50 Jesus Reyes Status new => assigned
2014-09-06 07:43 Jesus Reyes Fixed in Revision => 46137
2014-09-06 07:43 Jesus Reyes LazTarget => 1.4
2014-09-06 07:43 Jesus Reyes Status assigned => resolved
2014-09-06 07:43 Jesus Reyes Fixed in Version => 1.3 (SVN)
2014-09-06 07:43 Jesus Reyes Resolution open => fixed
2014-09-06 07:43 Jesus Reyes Target Version => 1.4
2014-09-09 15:32 Péter Gábor Note Added: 0077000
2014-09-09 15:32 Péter Gábor Status resolved => assigned
2014-09-09 15:32 Péter Gábor Resolution fixed => reopened
2014-09-09 15:39 Péter Gábor Note Edited: 0077000 View Revisions
2014-09-09 15:44 Péter Gábor Note Edited: 0077000 View Revisions
2014-09-09 18:42 Jesus Reyes Note Added: 0077007
2014-09-09 18:42 Jesus Reyes Status assigned => resolved
2014-09-09 18:42 Jesus Reyes Resolution reopened => fixed
2014-09-09 18:43 Jesus Reyes Note Edited: 0077007 View Revisions
2014-09-29 15:58 Péter Gábor Status resolved => closed