View Issue Details

IDProjectCategoryView StatusLast Update
0026527LazarusLCLpublic2014-08-25 09:08
ReporterpYskalAssigned ToMaxim Ganetsky 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindowsOS VersionXP
Product VersionProduct Build44758 
Target VersionFixed in Version1.4 
Summary0026527: In Lazarus PO translation mode: Strings marked as FUZZY are displayed.
DescriptionWhen using PO files to translate Lazarus apps, some strings are marked as FUZZY.
When PO files are used in native *nix apps, strings marked at FUZZY are a ignored.
But Lazarus does not ignore them, which is definitely a problem, because such strings often occur after automatic translation with for example PoEdit, whose automatic translations are often disastrous.
Example:
[code]#: tfobject3d.rendering.caption
#, fuzzy
msgid "Rendering"
msgstr "Измазване"[/code]
In an application, the displayed text shall be „Rendering“, because the entry is marked as fuzzy, but in Lazarus apps displayed text is „Измазване“.
Steps To ReproduceOpen a translation file for you language in ..\lazarus\languages\lazaruside.*.po
Edit the following entry

#: lazarusidestrconsts.lismenufile
#, fuzzy
msgid "&File"
msgstr "whatever_content"

to
#: lazarusidestrconsts.lismenufile
#, fuzzy
msgid "&File"
msgstr "&WrongContent"

Save the PO file and restart the Lazarus IDE.
In the main menu you will see „WrongContent“ instaed of „File“.
TagsNo tags attached.
Fixed in Revision46044
LazTarget-
Widgetset
Attached Files

Relationships

related to 0026423 closedMaxim Ganetsky Recent changes in resourcestring format has lead to incompatible format arguments in several po files. 

Activities

Maxim Ganetsky

2014-08-15 00:11

developer   ~0076604

Thanks for the hint!

Please test and close if OK.

Issue History

Date Modified Username Field Change
2014-07-25 09:28 pYskal New Issue
2014-07-26 01:14 Maxim Ganetsky Relationship added related to 0026423
2014-07-26 01:17 Maxim Ganetsky LazTarget => -
2014-07-26 01:17 Maxim Ganetsky Status new => confirmed
2014-08-15 00:11 Maxim Ganetsky Fixed in Revision => 46044
2014-08-15 00:11 Maxim Ganetsky Note Added: 0076604
2014-08-15 00:11 Maxim Ganetsky Status confirmed => resolved
2014-08-15 00:11 Maxim Ganetsky Fixed in Version => 1.4
2014-08-15 00:11 Maxim Ganetsky Resolution open => fixed
2014-08-15 00:11 Maxim Ganetsky Assigned To => Maxim Ganetsky