View Issue Details

IDProjectCategoryView StatusLast Update
0026532FPCCompilerpublic2020-04-13 22:18
Reporterdimprofi Assigned ToJonas Maebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version2.6.4 
Summary0026532: Wrong compile error message on long names
DescriptionToo long names of units/classes is not recognized, giving wrong message about a cause.
Steps To Reproduce// project1.lpr
//-----------------------------

program project1;

uses object_123456789012345678901234567890123456789012345678901234567890;


begin
  TObject_123456789012345678901234567890123456789012345678901234567890.Create();
end.



// object_123456789012345678901234567890123456789012345678901234567890.pas
//-----------------------------

unit object_123456789012345678901234567890123456789012345678901234567890;

{$mode objfpc}{$H+}

interface

uses
  Classes, SysUtils;

type
  TObject_123456789012345678901234567890123456789012345678901234567890=class
  end;


implementation

end.


//Getting error message on compile:
---
project1.lpr(8,1) Error: Undefined symbol: VMT_OBJECT_123456789012345678901234567890123456789012345678901234567890_TOBJECT_1234567890123456789012
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

dimprofi

2014-07-28 14:44

reporter  

project1.lpr (197 bytes)

dimprofi

2014-07-28 14:45

reporter  

dimprofi

2014-07-28 14:47

reporter   ~0076372

The solution would be just an error message: "Too long class/unit name!"
Or check the code for unnecessary limits in naming.

dimprofi

2014-07-28 14:48

reporter   ~0076373

I lost about two days to figure the cause out!

Jonas Maebe

2017-01-15 17:54

manager   ~0097498

On which platform and cpu architecture is this? (please always be complete when filing bug reports) It compiles fine on OS X, also with FPC 2.6.4.

Thaddy de Koning

2017-01-15 18:36

reporter   ~0097501

I suspect this is 32 bit Windows and related to MAX_PATH. On Linux this works as well.

Jonas Maebe

2017-01-15 18:42

manager   ~0097502

The error is about a symbol, not a file name. It's then probably related to either the internal assembler, internal linker, or the COFF file format.

Bart Broersma

2019-02-12 23:42

reporter   ~0114063

Last edited: 2019-02-12 23:42

View 2 revisions

Compiles and links fine on Windows with fpc 3.0.4 and 3.3.1, both 32 and crosscompiled to 64 bit (and wince for 3.04).

Bart Broersma

2020-04-13 13:26

reporter   ~0122117

No feedback in > 1 year.
Resolve as no change required?

Jonas Maebe

2020-04-13 13:32

manager   ~0122118

Indeed.

Issue History

Date Modified Username Field Change
2014-07-28 14:44 dimprofi New Issue
2014-07-28 14:44 dimprofi File Added: project1.lpr
2014-07-28 14:45 dimprofi File Added: object_123456789012345678901234567890123456789012345678901234567890.pas
2014-07-28 14:47 dimprofi Note Added: 0076372
2014-07-28 14:48 dimprofi Note Added: 0076373
2017-01-15 17:54 Jonas Maebe Note Added: 0097498
2017-01-15 17:54 Jonas Maebe Status new => feedback
2017-01-15 18:36 Thaddy de Koning Note Added: 0097501
2017-01-15 18:42 Jonas Maebe Note Added: 0097502
2019-02-12 23:42 Bart Broersma Note Added: 0114063
2019-02-12 23:42 Bart Broersma Note Edited: 0114063 View Revisions
2020-04-13 13:26 Bart Broersma Note Added: 0122117
2020-04-13 13:32 Jonas Maebe Assigned To => Jonas Maebe
2020-04-13 13:32 Jonas Maebe Status feedback => resolved
2020-04-13 13:32 Jonas Maebe Resolution open => unable to reproduce
2020-04-13 13:32 Jonas Maebe FPCTarget => -
2020-04-13 13:32 Jonas Maebe Note Added: 0122118