View Issue Details

IDProjectCategoryView StatusLast Update
0026658LazarusLCLpublic2014-09-05 19:37
ReporterMarkus MüllerAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformOSWin7OS Version
Product Version1.2.4Product Build 
Target VersionFixed in Version 
Summary0026658: TDBGrid make a TDataset.Cancel after exit Focus
DescriptionWhen the focus is in the TDBGrid and I take "Append" on TDataset, and then switch into (mouseclick) a TDBEdit then the TDBGrid lost focus and make cancel from the new Append command.
Steps To ReproduceLoad in attachment my demo, start it

- Click in the TDBGrid into Line "Zeile 2"
- Click the TSpeedButton "Append"
- Click into TDBEdit

Then there comes the Cancel Event vom TDataSet
Additional InformationThis demo use TMemoryDatase. My original application has from Zeos the TZQuery, but it's the same.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Markus Müller

2014-08-31 14:06

reporter  

TDBGridTest.zip (128,798 bytes)

Markus Müller

2014-08-31 14:27

reporter   ~0076803

In an prior Lazarus version was dgCancelOnExit not set. Now in the current Version 1.2.4 is it set to TRUE.
Please correct this default value back to FALSE.

Jesus Reyes

2014-09-03 05:05

developer   ~0076855

dgCancelOnExit has been set to true by default since it's implementation 10 years ago.

What Lazarus version (revision)?.

Markus Müller

2014-09-03 10:34

reporter   ~0076860

I think you have right. This option was set in SVN41721, too.
I think there was something wrong from update from this old SVN Version to the new official 1.2.4. But I do not know from what/where this set bit is coming (my source is very big).

You can close this Bugreport.

But I think it was better when then option dgCancelOnExit is false.

Thx.

Issue History

Date Modified Username Field Change
2014-08-31 14:05 Markus Müller New Issue
2014-08-31 14:06 Markus Müller File Added: TDBGridTest.zip
2014-08-31 14:27 Markus Müller Note Added: 0076803
2014-08-31 21:14 Jesus Reyes Assigned To => Jesus Reyes
2014-08-31 21:14 Jesus Reyes Status new => assigned
2014-09-03 05:05 Jesus Reyes LazTarget => -
2014-09-03 05:05 Jesus Reyes Note Added: 0076855
2014-09-03 05:05 Jesus Reyes Status assigned => feedback
2014-09-03 10:34 Markus Müller Note Added: 0076860
2014-09-03 10:34 Markus Müller Status feedback => assigned
2014-09-05 19:37 Jesus Reyes Status assigned => resolved
2014-09-05 19:37 Jesus Reyes Resolution open => no change required