View Issue Details

IDProjectCategoryView StatusLast Update
0026695LazarusLCLpublic2017-10-16 16:42
ReporterLionAssigned ToMichl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.4Product Build 
Target VersionFixed in Version1.9 (SVN) 
Summary0026695: ComboBox AutoComplete accepts no ItemIdex
DescriptionComboBox AutoComplete accepts no ItemIdex. See attachment, with sample project and video.
TagsAutoComplete, ComboBox, itemindex
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0020950 resolvedMichl TComboBox.AutoDropDown can lead to discrepant Text and ItemIndex values under win32 

Activities

Lion

2014-09-09 12:05

reporter  

ComboBoxBug.7z (1,656,656 bytes)

Juha Manninen

2014-09-09 12:59

developer   ~0076996

Your demo application makes no sense. It only has 2 button OnClick handlers with:
  ShowMessage(IntToStr(ComboBox1.ItemIndex));
in both of them.

Your video does not work either. Windows Media Player encountered a problem.

Do you mean by your report: "AutoCompleted ComboBox value does not change ItemIndex"?
It feels like a bug although Delphi (2007) has almost the same bug.
Delphi changes ItemIndex with a delay. If you do many autocompletions, ItemIndex always points to the previous selection. It is clearly a bug in Delphi.

I suggest we change to a more logical behavior so that ItemIndex gets updated to the autocompleted index.
We don't need to replicate Delphi's bugs after all.

Vojtech Cihak

2014-09-09 17:20

reporter   ~0077003

I can reproduce in Win and GTK2, while Qt seems to be OK.
Note: In Qt and GTK2 is difficult to test when AutoDropDown=True.

Lion

2014-09-09 19:31

reporter   ~0077009

Show the video with VLC player.

Michl

2017-10-13 15:17

developer   ~0103407

Tested with Windows 7 (win32), Linux Mint 17.3 KDE (GTK2, QT). All works fine. So this issue seems to be fixed in meantime.

Issue History

Date Modified Username Field Change
2014-09-09 12:05 Lion New Issue
2014-09-09 12:05 Lion File Added: ComboBoxBug.7z
2014-09-09 12:59 Juha Manninen Note Added: 0076996
2014-09-09 17:20 Vojtech Cihak Note Added: 0077003
2014-09-09 19:31 Lion Note Added: 0077009
2014-09-09 19:32 Lion Tag Attached: ComboBox
2014-09-09 19:32 Lion Tag Attached: itemindex
2014-09-09 19:33 Lion Tag Attached: AutoComplete
2014-09-10 00:38 Juha Manninen Relationship added related to 0020950
2017-10-13 15:15 Michl Assigned To => Michl
2017-10-13 15:15 Michl Status new => assigned
2017-10-13 15:17 Michl LazTarget => -
2017-10-13 15:17 Michl Note Added: 0103407
2017-10-13 15:17 Michl Status assigned => resolved
2017-10-13 15:17 Michl Fixed in Version => 1.9 (SVN)
2017-10-13 15:17 Michl Resolution open => fixed