View Issue Details

IDProjectCategoryView StatusLast Update
0026714LazarusLCLpublic2014-09-13 20:34
ReporterAnthony TekatchAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.4Product Buildi386-linux-gtk 2 
Target VersionFixed in Version1.3 (SVN) 
Summary0026714: Radiogroup does not updated clicked button when in non-visible TPageControl tab
DescriptionRadio group event OnSelectionChanged (and also OnClick) is not triggered when a new click to a button is made when that radio group is located on a tab that was made invisible during a programmatical ItemIndex change.
Steps To ReproduceI have attached an example application:
- run it and select Sheet 2
- Click on item "one", and watch that the Changed counter increases like it should
- Select "Sheet 1"
- press "Hide sheet 2"
- press "set to 0", notice that the Changed counter increases again like it should
- Press "Show sheet 2"
- Select "Sheet 2"
- radio will be on "zero" because of previous change
- Click on item "one", notice that Changed does not increase.

It is as if the radiogroup remembered what was manually clicked, but during invisibility, the ItemIndex can still be functionally changed correctly. A click to that different an previously remembered item is not registered as a new "OnSelectionChanged" event.

TagsNo tags attached.
Fixed in Revision46208
LazTarget1.2.6
WidgetsetGTK 2, Win32/Win64, WinCE, Carbon, Cocoa, QT
Attached Files

Activities

Anthony Tekatch

2014-09-13 02:44

reporter  

publishedproject.zip (3,100 bytes)

Zeljan Rikalo

2014-09-13 16:15

developer   ~0077190

It does not work under qt too. It's possible that this is LCL bug.

Zeljan Rikalo

2014-09-13 16:18

developer   ~0077192

Changed widgetset from GTK2 to all since it affects (tested mentioned) Gtk2, Qt and Win32, so LCL is suspected.

Zeljan Rikalo

2014-09-13 16:37

developer   ~0077193

Please test and close if ok.

Anthony Tekatch

2014-09-13 20:34

reporter   ~0077200

That works fine. Thank you!
Case closed.

Issue History

Date Modified Username Field Change
2014-09-13 02:44 Anthony Tekatch New Issue
2014-09-13 02:44 Anthony Tekatch File Added: publishedproject.zip
2014-09-13 16:15 Zeljan Rikalo LazTarget => -
2014-09-13 16:15 Zeljan Rikalo Note Added: 0077190
2014-09-13 16:15 Zeljan Rikalo Assigned To => Zeljan Rikalo
2014-09-13 16:15 Zeljan Rikalo Status new => feedback
2014-09-13 16:18 Zeljan Rikalo Widgetset GTK 2 => GTK 2, Win32/Win64, WinCE, Carbon, Cocoa, QT
2014-09-13 16:18 Zeljan Rikalo Note Added: 0077192
2014-09-13 16:37 Zeljan Rikalo Fixed in Revision => 46208
2014-09-13 16:37 Zeljan Rikalo LazTarget - => 1.2.6
2014-09-13 16:37 Zeljan Rikalo Note Added: 0077193
2014-09-13 16:37 Zeljan Rikalo Status feedback => resolved
2014-09-13 16:37 Zeljan Rikalo Fixed in Version => 1.3 (SVN)
2014-09-13 16:37 Zeljan Rikalo Resolution open => fixed
2014-09-13 20:34 Anthony Tekatch Note Added: 0077200
2014-09-13 20:34 Anthony Tekatch Status resolved => closed