View Issue Details

IDProjectCategoryView StatusLast Update
0026728LazarusLazReportpublic2014-09-29 15:58
ReporterPéter GáborAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3 (SVN)Product Build 
Target Version1.4Fixed in Version1.3 (SVN) 
Summary0026728: lr_OfficeImport: Wrong number of parameters specified for call to "GetLastRowIndex" and "GetLastColIndex"
Descriptionlr_OfficeImport: Wrong number of parameters specified for call to "GetLastRowIndex" and "GetLastColIndex"

lrspreadsheetimportunit.pas(141,50) Hiba: Wrong number of parameters specified for call to "GetLastRowIndex"
fpspreadsheet.pas(1728,22) Tipp: Found declaration: TsWorksheet.GetLastRowIndex:DWord;
lrspreadsheetimportunit.pas(145,52) Hiba: Wrong number of parameters specified for call to "GetLastColIndex"
fpspreadsheet.pas(1646,22) Tipp: Found declaration: TsWorksheet.GetLastColIndex:DWord;

Calls are:
  FWorksheet.GetLastRowIndex(False)
  FWorksheet.GetLastColIndex(false)
but declarations are without parameters...
TagsNo tags attached.
Fixed in Revision46255
LazTarget1.4
Widgetset
Attached Files

Activities

wp

2014-09-18 16:49

developer   ~0077364

Last edited: 2014-09-18 16:55

View 2 revisions

fpspreadsheet is seeing a lot of changes these days, and an optional boolean parameter has been added to GetLastRow/ColIndex. The default value of this parameter is false. Ttherefore, the code should work with older versions of fpspreadsheet if the "(false)" mentioned in the description would simply be omitted. However, I am not familiar with the internal details and don't know of other incompatibilities.

Jesus Reyes

2014-09-18 19:49

developer   ~0077368

@wp: thanks for the feedback.

This means the reporter is using an old version(or revision) of fpspreadsheet.

Something that we can do is setting a minimun requirement for fpspreadsheet on lr_OfficeImport. I will investigate if the parameter change can be tracked down to a different version and use it for lr_officeImport, if such revision can't be identified there is nothing to do than keep updated one's copy of fpspreadsheet.

I think there is nothing left in this issue and if reporter agree please close it.

wp

2014-09-18 20:36

developer   ~0077371

As far as I can tell by a quick inspection the only new features that you are using since I've been involved in fpspreadsheet is the text alignment and the text font. They are supported by the last stable versions 1.2 and 1.2.1.

Péter Gábor

2014-09-19 08:27

reporter   ~0077387

This bug-report applies to fpspreadsheet 1.2.1 (downloaded from lazarus-ccr) so it's not an old version...

wp

2014-09-19 09:09

developer   ~0077393

Last edited: 2014-09-19 10:05

View 3 revisions

@_Gabor: You are right - the parameter was added to GetLastCol/RowIndex in trunk.

@Jesus Reyes: The issue is not fixed yet since the current lazReport still has these parameters in the code. You have to remove the "(false)"

  Y:=0;
  for Row:=0 to FWorksheet.GetLastRowIndex-1 do // remove "(false)"
  begin
    X:=0;
    DY:=CalcRowHeight(FWorksheet.GetRowHeight(Row));
    for Col:=0 to FWorksheet.GetLastColIndex-1 do // remove "(false)"
    begin
      Cell := FWorksheet.FindCell(Row, Col);
    ....

With these changes, the component compiles also with fpspreadsheet 1.2/1.2.1

Jesus Reyes

2014-09-19 19:33

developer   ~0077436

Well, evidently the lr_OfficeImport package was designed to work with fpSpreadSheet trunk version, that is why I said the reporter was trying an old version of fpspreadsheet package (any version that is not trunk is an older version of what lr_OfficeImport needed, that includes the 1.2.1 or older released versions).

Anyway, I have modified the lr_OfficeImport package as wp indicated, I also think this is much better. If fpSpreadsheet package trunk version could be marked with version bigger than 1.2.1 it would be even better.

Please test.

Issue History

Date Modified Username Field Change
2014-09-16 10:27 Péter Gábor New Issue
2014-09-18 16:41 Jesus Reyes Assigned To => Jesus Reyes
2014-09-18 16:41 Jesus Reyes Status new => assigned
2014-09-18 16:49 wp Note Added: 0077364
2014-09-18 16:55 wp Note Edited: 0077364 View Revisions
2014-09-18 19:49 Jesus Reyes LazTarget => -
2014-09-18 19:49 Jesus Reyes Note Added: 0077368
2014-09-18 19:49 Jesus Reyes Status assigned => resolved
2014-09-18 19:49 Jesus Reyes Fixed in Version => 1.3 (SVN)
2014-09-18 19:49 Jesus Reyes Resolution open => fixed
2014-09-18 20:36 wp Note Added: 0077371
2014-09-19 08:27 Péter Gábor Note Added: 0077387
2014-09-19 09:09 wp Note Added: 0077393
2014-09-19 09:14 Péter Gábor Status resolved => assigned
2014-09-19 09:14 Péter Gábor Resolution fixed => reopened
2014-09-19 10:05 wp Note Edited: 0077393 View Revisions
2014-09-19 10:05 wp Note Edited: 0077393 View Revisions
2014-09-19 19:33 Jesus Reyes Fixed in Revision => 46255
2014-09-19 19:33 Jesus Reyes LazTarget - => 1.4
2014-09-19 19:33 Jesus Reyes Note Added: 0077436
2014-09-19 19:33 Jesus Reyes Status assigned => resolved
2014-09-19 19:33 Jesus Reyes Resolution reopened => fixed
2014-09-19 19:33 Jesus Reyes Target Version => 1.4
2014-09-29 15:58 Péter Gábor Status resolved => closed