View Issue Details

IDProjectCategoryView StatusLast Update
0026745LazarusWidgetsetpublic2014-09-21 13:05
ReporterVojtech Cihak Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformamd64OSLinux 
Product Version1.3 (SVN) 
Summary0026745: [Qt] CopyRect - regression of 26004
DescriptionCopyRect should copy only a piece of canvas but it stretch-copy all.
This is regression of 26004.
Steps To ReproduceUse the demo attached here: http://bugs.freepascal.org/view.php?id=26004

Click on InvalidateRect shows red/yellow rectangle while it should be only red.
Additional InformationLazarus 1.3 r46204M FPC 2.7.1 x86_64-linux-qt
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetQT
Attached Files

Relationships

duplicate of 0026744 closedZeljan Rikalo [Qt] CopyRect - regression of 26004 
related to 0026004 closedZeljan Rikalo CopyRect+InvalidateRect issue [Qt] 

Activities

Vojtech Cihak

2014-09-19 15:57

reporter   ~0077418

Sorry, I reported twice. Please close or delete this one, lets keep 26744 only.

Zeljan Rikalo

2014-09-21 12:16

developer   ~0077480

Resolved as duplicate.

Vojtech Cihak

2014-09-21 13:05

reporter   ~0077482

Closed as duplicate.

Issue History

Date Modified Username Field Change
2014-09-19 15:54 Vojtech Cihak New Issue
2014-09-19 15:57 Vojtech Cihak Note Added: 0077418
2014-09-19 16:00 Vincent Snijders Relationship added related to 0026004
2014-09-19 17:23 Zeljan Rikalo Assigned To => Zeljan Rikalo
2014-09-19 17:23 Zeljan Rikalo Status new => assigned
2014-09-21 12:16 Zeljan Rikalo Relationship added duplicate of 0026744
2014-09-21 12:16 Zeljan Rikalo LazTarget => -
2014-09-21 12:16 Zeljan Rikalo Note Added: 0077480
2014-09-21 12:16 Zeljan Rikalo Status assigned => resolved
2014-09-21 12:16 Zeljan Rikalo Resolution open => duplicate
2014-09-21 13:05 Vojtech Cihak Note Added: 0077482
2014-09-21 13:05 Vojtech Cihak Status resolved => closed