View Issue Details

IDProjectCategoryView StatusLast Update
0026770LazarusWidgetsetpublic2015-05-30 00:52
ReporterBart BroersmaAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSLinuxOS VersionFedora Core 18
Product Version1.3 (SVN)Product Buildr46309 
Target Version1.2.6Fixed in Version1.3 (SVN) 
Summary0026770: TListView: icons are too smaal on QT Linux
DescriptionWith Reportstye = vsIcon and (only) LargeImages assigned, the icons showing up in the ListView are much smaller than the bitmaps in the LargeImages TImagelist.
Steps To ReproduceUnzip and open attached project.
Make sure buildmode is set to Qt (ProjectOptions)
Build and run.
The images (created @runtime) are 80 pixels (W&H), but they shw considerably smaller.
Switch buildmode to GTK2 to see the difference.
TagsNo tags attached.
Fixed in Revision46310,46313
LazTarget1.2.6
WidgetsetQT
Attached Files

Relationships

related to 0027043 closedZeljan Rikalo TListView does not allow setting item height with GTK2 and QT 
related to 0028212 closedZeljan Rikalo TreeView item width set to -1 and do not show 

Activities

Bart Broersma

2014-09-24 17:04

developer  

lv.zip (3,308 bytes)

Zeljan Rikalo

2014-09-24 18:33

developer   ~0077598

Please test and close if ok.

Zeljan Rikalo

2014-09-24 19:07

developer   ~0077602

r46313 removes r46310 because I've added RecreateWnd there.
Now changes with imagelists are imediatelly visible in designer and runtime (eg. you switch imagelists with different icons or sizes).
Please test and close if ok.

Bart Broersma

2014-09-24 23:30

developer   ~0077615

Fixed.

Issue History

Date Modified Username Field Change
2014-09-24 17:04 Bart Broersma New Issue
2014-09-24 17:04 Bart Broersma File Added: lv.zip
2014-09-24 17:33 Zeljan Rikalo Assigned To => Zeljan Rikalo
2014-09-24 17:33 Zeljan Rikalo Status new => assigned
2014-09-24 18:33 Zeljan Rikalo Fixed in Revision => 46310
2014-09-24 18:33 Zeljan Rikalo Note Added: 0077598
2014-09-24 18:33 Zeljan Rikalo Status assigned => resolved
2014-09-24 18:33 Zeljan Rikalo Resolution open => fixed
2014-09-24 19:06 Zeljan Rikalo Status resolved => assigned
2014-09-24 19:06 Zeljan Rikalo Resolution fixed => reopened
2014-09-24 19:07 Zeljan Rikalo Fixed in Revision 46310 => 46310,46313
2014-09-24 19:07 Zeljan Rikalo LazTarget - => 1.2.6
2014-09-24 19:07 Zeljan Rikalo Note Added: 0077602
2014-09-24 19:07 Zeljan Rikalo Status assigned => resolved
2014-09-24 19:07 Zeljan Rikalo Fixed in Version => 1.3 (SVN)
2014-09-24 19:07 Zeljan Rikalo Resolution reopened => fixed
2014-09-24 19:07 Zeljan Rikalo Target Version => 1.2.6
2014-09-24 23:30 Bart Broersma Note Added: 0077615
2014-09-24 23:30 Bart Broersma Status resolved => closed
2014-11-15 08:38 Zeljan Rikalo Relationship added related to 0027043
2015-05-30 00:52 Juha Manninen Relationship added related to 0028212