View Issue Details

IDProjectCategoryView StatusLast Update
0026839LazarusIDEpublic2014-10-12 23:16
ReporterMaxim GanetskyAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWin32OSWindowsOS VersionXP SP3 32-bit
Product Version1.3 (SVN)Product Buildr46470 FPC 2.6.4 i386-win32 
Target Version1.4Fixed in Version1.4 
Summary0026839: [regression] Broken items selection in "Search Results" window
Description"Search Results" window allows to select two and more items at once and seems to process mouse left clicks strangely (it "lags").

See attached screenshot. Bug seems not to be dependent on OS/widgetset.
Steps To Reproduce1. Find something that will return several search results.
2. Select any item in search results (with left click).
3. Select any other item with left click (you should press LMB down, move mouse a little and release LMB).
TagsNo tags attached.
Fixed in Revision46505
LazTarget1.4
Widgetset
Attached Files

Activities

Maxim Ganetsky

2014-10-09 22:59

developer  

Search.png (79,021 bytes)
Search.png (79,021 bytes)

Juha Manninen

2014-10-10 01:17

developer   ~0078125

It is caused by r45971 made by Mattias:
 LCL: TTreeView: mouse click without Shift/Ctrl: single select only if mouse up on mouse down node

from July 25.

Maxim Ganetsky

2014-10-12 23:16

developer   ~0078182

Works OK, thanks.

Issue History

Date Modified Username Field Change
2014-10-09 22:59 Maxim Ganetsky New Issue
2014-10-09 22:59 Maxim Ganetsky File Added: Search.png
2014-10-09 23:01 Maxim Ganetsky LazTarget - => 1.4
2014-10-09 23:01 Maxim Ganetsky Description Updated View Revisions
2014-10-10 01:17 Juha Manninen Note Added: 0078125
2014-10-10 01:17 Juha Manninen Assigned To => Mattias Gaertner
2014-10-10 01:17 Juha Manninen Status new => assigned
2014-10-10 02:21 Mattias Gaertner Fixed in Revision => 46505
2014-10-10 02:21 Mattias Gaertner Status assigned => resolved
2014-10-10 02:21 Mattias Gaertner Resolution open => fixed
2014-10-12 23:16 Maxim Ganetsky Note Added: 0078182
2014-10-12 23:16 Maxim Ganetsky Status resolved => closed
2014-10-12 23:16 Maxim Ganetsky Fixed in Version => 1.4