View Issue Details

IDProjectCategoryView StatusLast Update
0026886LazarusIDEpublic2020-03-30 21:41
ReporterNever Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
OSwin7 64 bit 
Product Version1.2.6 
Summary0026886: Code Eplorer refresh issue
Descriptionfrom ide options/code explorer/update click on [ when switching file in source editor ] did not test the behaivor with other settings....
now open at least 2 files in source editor file [a] and file [b]
select [a] and type a search term in code explorer [at (filter)] that you are sure that exists in both files.
search is done and you have a closed tree with the results.
now switch to file [b]
the code explorer is displaying search results from file [b]
and if the term exists the tree opens and shows as selected/shadowed a random!!! item of the tree .
now go back to your file [a] the tree remains closed
imho
in general since a search is done and there are results
the tree should be opened with the first found match
 shadowed/selected .
beond that there are sometimes that the refresh is not taking place at all but i wasn't able to spot them exactly just mentioned here if you know it happens you might spot it easyer than me.

TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Juha Manninen

2020-03-30 21:41

developer   ~0121785

Now it works well. Please test.

Issue History

Date Modified Username Field Change
2014-10-18 17:05 Never New Issue
2020-03-30 20:55 Juha Manninen Assigned To => Juha Manninen
2020-03-30 20:55 Juha Manninen Status new => assigned
2020-03-30 21:41 Juha Manninen Status assigned => resolved
2020-03-30 21:41 Juha Manninen Resolution open => fixed
2020-03-30 21:41 Juha Manninen LazTarget => -
2020-03-30 21:41 Juha Manninen Note Added: 0121785