View Issue Details

IDProjectCategoryView StatusLast Update
0026895LazarusPackagespublic2016-01-01 10:42
ReporterJuha Manninen Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
PlatformLinux + KDE + QTOSLinux Mint 
Product Version1.3 (SVN) 
Summary0026895: AnchorDocking: Messages window either disappears or becomes very small in some situations
DescriptionThis is not 100% reproducible. I guess there are uninitialized variables involved or something similar.
The default layout without any anchordocklayout.xml contains source editor, messages window below it and Code Explorer on the right.
The Steps to Reproduce below assumes the default layout.

In case 1 the Messages window becomes small. It may be related to 0018538 but the effect is more dramatic. There must be a docked window on the left side that occupies all the vertical space from top to bottom.
After deleting the default anchordocklayout.xml and trying again with same steps ... I could not reproduce! Must be uninitialized memory.

In case 2 the Messages window disappears.
This one I can reproduce always.
Steps To ReproduceCase 1: Messages window becomes small.
1. Show OI (F11) and dock it on left side of Source editor.
2. Dock Messages window below Source editor. Now they are both on the right side of OI and OI's height is from top to bottom.
3. Resize the IDE by crabbing its corner. Messages window becomes very low.

Case 2: Message window disappears.
1. Do steps 1 and 2 of case 1.
2. Show Component list (Ctrl-Alt-P) and dock it on right side of Source editor. Now both Source editor and Component list are above Messages window. Messages window is between OI and Code exprorer side-ways.
3. Tools -> Save window layout as default.
4. Close and restart the IDE.
5. Resize the IDE by crabbing its corner. Messages window disappears. The 2 windows above it, SE and Code explorer, extend below the IDE's bottom edge and become partly invisible.
TagsNo tags attached.
Fixed in Revision51098,51099
LazTarget-
WidgetsetQT
Attached Files

Relationships

related to 0018538 closedJuha Manninen Under certain configurations docked windows, lower window arbitrarily increasing its height 
related to 0026893 closedZeljan Rikalo AnchorDocking crashes with Object inspector 
related to 0018298 resolvedMattias Gaertner Please update the default layout provided with anchor docking package 
related to 0029298 closedOndrej Pokorny Docked window height changes when changing the dock site width 

Activities

Zeljan Rikalo

2014-10-20 11:43

developer   ~0078414

This is reproducible only when "Scale on resize" is enabled.

Juha Manninen

2014-11-04 20:26

developer   ~0078902

Now I realized this is also a QT related issue. The same thing does not happen with GTK2 or Windows, not the same way anyway. How is the layout system different in QT?

I noticed the same thing happens with GlassDocking taken from CodeTyphon. It can be compiled and tested with standard Lazarus easily.
They have not made any big changes, mostly formatting.

Juha Manninen

2015-12-29 22:41

developer   ~0088417

Zeljko, where is the "Scale on resize" option?
I cannot reproduce this any more. I think it was solved by r51081.

Zeljan Rikalo

2015-12-30 19:47

developer   ~0088444

It is somewhere in Options -> Anchordocking settings (or similar name), I don't use anchordocking so cannot point you to the right direction atm.

Juha Manninen

2016-01-01 10:39

developer   ~0088487

Fixed together with related issues.

Issue History

Date Modified Username Field Change
2014-10-19 13:11 Juha Manninen New Issue
2014-10-19 13:11 Juha Manninen Status new => assigned
2014-10-19 13:11 Juha Manninen Assigned To => Mattias Gaertner
2014-10-19 13:14 Juha Manninen Description Updated View Revisions
2014-10-19 13:15 Juha Manninen Relationship added related to 0018538
2014-10-19 13:15 Juha Manninen Relationship added related to 0026893
2014-10-19 19:01 Mattias Gaertner Relationship added related to 0018298
2014-10-20 11:43 Zeljan Rikalo Note Added: 0078414
2014-11-04 20:26 Juha Manninen Note Added: 0078902
2014-11-04 20:26 Juha Manninen OS => Linux Mint
2014-11-04 20:26 Juha Manninen OS Version => 17
2014-11-04 20:26 Juha Manninen Platform => Linux + KDE + QT
2014-11-04 20:26 Juha Manninen Widgetset => QT
2015-12-29 22:38 Juha Manninen Assigned To Mattias Gaertner => Juha Manninen
2015-12-29 22:41 Juha Manninen Note Added: 0088417
2015-12-30 19:47 Zeljan Rikalo Note Added: 0088444
2016-01-01 10:37 Juha Manninen Relationship added related to 0029298
2016-01-01 10:39 Juha Manninen Fixed in Revision => 51098,51099
2016-01-01 10:39 Juha Manninen Note Added: 0088487
2016-01-01 10:39 Juha Manninen Status assigned => resolved
2016-01-01 10:39 Juha Manninen Resolution open => fixed
2016-01-01 10:42 Juha Manninen Status resolved => closed