View Issue Details

IDProjectCategoryView StatusLast Update
0026908LazarusIDEpublic2020-03-30 21:40
ReporterNever Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
OSwin7 64bit 
Product Version1.2.6 
Summary0026908: Code Explorer Procedure locator
Descriptionwhen right click on code explorer and select jump to implementation
there are occasions that the identifier in question is not displayed as supposed to be usually this happens when the procedure function is just after the current procedure function
one of these occasions spot it and described
 hope all of them are related and this will help to fix all.
Steps To Reproducecreate a new project
add a button
from object inspector go to events tab
double click on onClick
double click on onContextPopUp
now go to code explorer and type 'butt'
if haven't save press refresh to reload the tree
you should see the 2 event handlers there
now go to your source editor at [ procedure TForm1.Button1Click(Sender: TObject); ]
type or just hit enter (7 times i think is the correct one) until the button1ContextPopUp event handler header is one line under the visable area/just under the HScrollBar
now go to the code explorer and right click on button1ContextPopUp and select jump to implementation
voila nothing happens the event handler remains under the hscrollbar
i think this is related with the fact the every identifier after found displayed at the midle of the source editors visile screen and not at 2 or 3 lines from the top as it should be.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Juha Manninen

2020-03-30 21:40

developer   ~0121784

> i think this is related with the fact the every identifier after found displayed at the midle of the source editors visile screen and not at 2 or 3 lines from the top as it should be.

No. It happens because the Code Explorer view is not updated automatically. You may have updated it manually before adding lines to the source. Code Explorer has outdated information then.
Assuming you have the default setting "Refresh automatically" -> "When switching file in source editor".
You have 3 ways to fix the error:
1. Click Refresh button in Code Explorer _after_ all edits.
2. Switch to another source editor file and then back. Code Explorer gets updated.
3. Use the "Refresh automatically" -> "On idle" option. It works beautifully and may be the best option for you.

Issue History

Date Modified Username Field Change
2014-10-20 20:19 Never New Issue
2014-10-29 23:38 Mattias Gaertner Assigned To => Mattias Gaertner
2014-10-29 23:38 Mattias Gaertner Status new => assigned
2020-03-30 21:05 Juha Manninen Assigned To Mattias Gaertner => Juha Manninen
2020-03-30 21:40 Juha Manninen Status assigned => resolved
2020-03-30 21:40 Juha Manninen Resolution open => no change required
2020-03-30 21:40 Juha Manninen LazTarget => -
2020-03-30 21:40 Juha Manninen Note Added: 0121784