View Issue Details

IDProjectCategoryView StatusLast Update
0026939FPCCompilerpublic2015-10-02 14:12
ReporterAndrey Paramonov Assigned ToSven Barth  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Platformx86-64OSMicrosoft Windows 
Product Version2.6.4 
Summary0026939: Error compiling nested templates
DescriptionTo reproduce:
>fpc -MDelphi test.dpr
Free Pascal Compiler version 2.7.1 [2014/01/09] for x86_64
Copyright (c) 1993-2013 by Florian Klaempfl and others
Target OS: Win64 for x64
Compiling test.dpr
test.dpr(20,57) Fatal: Syntax error, ">" expected but "<" found
Fatal: Compilation aborted
Tagsgenerics
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0024283 resolvedSven Barth Generics syntax error, ">" expected but "<" found 

Activities

Andrey Paramonov

2014-10-25 09:52

reporter  

test.dpr (612 bytes)

Andrey Paramonov

2015-09-30 09:17

reporter   ~0086176

Reproducible for 3.0.0 rc1.

Thaddy de Koning

2015-09-30 10:20

reporter   ~0086178

And trunk r31894

Sven Barth

2015-10-02 14:12

manager   ~0086216

This was already reported in 0024283 and is a known shortcoming.

Regards,
Sven

Issue History

Date Modified Username Field Change
2014-10-25 09:52 Andrey Paramonov New Issue
2014-10-25 09:52 Andrey Paramonov File Added: test.dpr
2014-10-25 10:39 Cyrax Tag Attached: generics
2015-09-30 09:17 Andrey Paramonov Note Added: 0086176
2015-09-30 10:20 Thaddy de Koning Note Added: 0086178
2015-10-02 14:12 Sven Barth Note Added: 0086216
2015-10-02 14:12 Sven Barth Relationship added duplicate of 0024283
2015-10-02 14:12 Sven Barth Status new => resolved
2015-10-02 14:12 Sven Barth Resolution open => duplicate
2015-10-02 14:12 Sven Barth Assigned To => Sven Barth