View Issue Details

IDProjectCategoryView StatusLast Update
0026941LazarusConverterpublic2021-04-22 07:38
Reporterdonovaly Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformWindowsOS Win 7 
Product Version1.2.6 
Summary0026941: Delphi conversion removes properties of TBitBtn
Description- convert the attached project to Lazarus

The result are two forms where one form has a TBitBtn. This button has in Delphi the properties
* kind:= bkOK
* Caption:= 'OK'
* ModalResult:= mrOK

After the conversion all 3 properties vanished wich is a dataloss
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0038783 assignedJuha Manninen TBitBtn Import Loses Information 
related to 0024772 assignedJuha Manninen TBitBtn : bkOK does not match Delphi 6 behaviour 

Activities

donovaly

2014-10-25 14:47

reporter  

TBitBtn-bug-test.zip (24,129 bytes)

donovaly

2014-10-25 14:48

reporter  

LazDelphiConversionSettings.jpg (79,551 bytes)   
LazDelphiConversionSettings.jpg (79,551 bytes)   

donovaly

2014-10-25 14:48

reporter   ~0078607

I added an image showing my conversion settings

Juha Manninen

2014-10-25 16:33

developer   ~0078608

A patch to fix this would be nice of course. I have a long ToDo list.

donovaly

2014-10-27 13:18

reporter   ~0078647

> A patch to fix this would be nice of course.

I am a newbie who started using Lazarus for real-life programs 2 weeks ago. So sorry that I cannot provide patches as I know not enough about Lazarus.

donovaly

2015-04-25 01:11

reporter   ~0083183

In Lazarus 1.4.0 it is a bit better. Now only these 2 properties are lost during the conversation:

* Caption:= 'OK'
* ModalResult:= mrOK

donovaly

2019-05-04 19:59

reporter   ~0116003

In Lazarus 2.2.0 still these 2 properties are lost during the conversation:

* Caption:= 'OK'
* ModalResult:= mrOK

Juha Manninen

2021-04-21 20:29

developer   ~0130502

> The result are two forms where one form has a TBitBtn. This button has in Delphi the properties
> * kind:= bkOK
> * Caption:= 'OK'
> * ModalResult:= mrOK

No it doesn't. This is from your SamplingRateDialog.dfm file :
  object BitBtn1: TBitBtn
    Left = 128
    Top = 40
    Width = 49
    Height = 25
    TabOrder = 2
    Kind = bkOK
  end

The test project also has lots of stuff not relevant to this issue.
Please provide a simple valid test case.

donovaly

2021-04-22 02:42

reporter   ~0130506

Please close the bug. It is 7 years old and I have no longer access to Delphi or Delphi files.

Juha Manninen

2021-04-22 07:38

developer   ~0130507

Ok, I mark this as duplicate for the new issue. Apparently there is something about TBitBtn although I could not reproduce yet.

Issue History

Date Modified Username Field Change
2014-10-25 14:46 donovaly New Issue
2014-10-25 14:47 donovaly File Added: TBitBtn-bug-test.zip
2014-10-25 14:48 donovaly File Added: LazDelphiConversionSettings.jpg
2014-10-25 14:48 donovaly Note Added: 0078607
2014-10-25 15:58 Juha Manninen Relationship added related to 0024772
2014-10-25 15:58 Juha Manninen Assigned To => Juha Manninen
2014-10-25 15:58 Juha Manninen Status new => assigned
2014-10-25 15:58 Juha Manninen LazTarget => -
2014-10-25 15:58 Juha Manninen Category => Converter
2014-10-25 16:33 Juha Manninen Note Added: 0078608
2014-10-27 13:18 donovaly Note Added: 0078647
2015-04-25 01:11 donovaly Note Added: 0083183
2019-05-04 19:59 donovaly Note Added: 0116003
2021-04-21 19:54 Juha Manninen Relationship added related to 0038783
2021-04-21 20:29 Juha Manninen Note Added: 0130502
2021-04-22 02:42 donovaly Note Added: 0130506
2021-04-22 07:38 Juha Manninen Status assigned => resolved
2021-04-22 07:38 Juha Manninen Resolution open => duplicate
2021-04-22 07:38 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2021-04-22 07:38 Juha Manninen Note Added: 0130507
2021-04-22 07:38 Juha Manninen Relationship replaced duplicate of 0038783