View Issue Details

IDProjectCategoryView StatusLast Update
0026971LazarusLazReportpublic2017-09-17 08:53
ReporterGabor BorosAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86-64OSLinuxOS VersionKubuntu 14.04.1
Product Version1.3 (SVN)Product Build46697 
Target VersionFixed in Version1.9 (SVN) 
Summary0026971: Exception at application start
DescriptionException raised if the application started from the IDE with message "The paper "..." has no defined rectangle!" and repeated with many paper sizes. Can print from report designer and IDE too. Used CUPS-PDF. If the executable started outside from the IDE exception not raised.
TagsNo tags attached.
Fixed in Revision55874
LazTargetpost 1.8
WidgetsetQT
Attached Files

Activities

Gabor Boros

2014-10-30 12:05

reporter  

Qt_Lazreport_Paper.jpg (19,554 bytes)
Qt_Lazreport_Paper.jpg (19,554 bytes)

Gabor Boros

2014-10-30 12:05

reporter  

Qt_Lazreport_Paper.tar.gz (127,320 bytes)

Zeljan Rikalo

2014-10-30 16:57

developer   ~0078754

Usually, I disable EPrinter exceptions and then there's no errors around when running from ide.

Gabor Boros

2014-10-30 19:46

reporter   ~0078762

No exception if the project compiled for GTK2.

Zeljan Rikalo

2014-11-12 10:08

developer   ~0079107

hm..it looks like TQtPrinter object isn't created yet, so no available papers.

Jesus Reyes

2017-09-16 17:58

developer   ~0102868

Please test

Gabor Boros

2017-09-17 08:53

reporter   ~0102882

Tested with trunk 55849 and no exception. Thank you!

Issue History

Date Modified Username Field Change
2014-10-30 12:05 Gabor Boros New Issue
2014-10-30 12:05 Gabor Boros File Added: Qt_Lazreport_Paper.jpg
2014-10-30 12:05 Gabor Boros File Added: Qt_Lazreport_Paper.tar.gz
2014-10-30 16:57 Zeljan Rikalo LazTarget => -
2014-10-30 16:57 Zeljan Rikalo Note Added: 0078754
2014-10-30 16:57 Zeljan Rikalo Assigned To => Zeljan Rikalo
2014-10-30 16:57 Zeljan Rikalo Status new => assigned
2014-10-30 19:46 Gabor Boros Note Added: 0078762
2014-11-12 10:08 Zeljan Rikalo Note Added: 0079107
2017-09-16 17:47 Jesus Reyes Assigned To Zeljan Rikalo => Jesus Reyes
2017-09-16 17:58 Jesus Reyes Fixed in Revision => 55874
2017-09-16 17:58 Jesus Reyes LazTarget - => post 1.8
2017-09-16 17:58 Jesus Reyes Note Added: 0102868
2017-09-16 17:58 Jesus Reyes Status assigned => resolved
2017-09-16 17:58 Jesus Reyes Fixed in Version => 1.9 (SVN)
2017-09-16 17:58 Jesus Reyes Resolution open => fixed
2017-09-17 08:53 Gabor Boros Note Added: 0102882
2017-09-17 08:53 Gabor Boros Status resolved => closed