View Issue Details

IDProjectCategoryView StatusLast Update
0027116LazarusLCLpublic2014-12-02 10:12
ReporterTorsten Bonde ChristiansenAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSLinuxOS VersionN/A
Product Version1.3 (SVN)Product Build47043 
Target Version1.2.8Fixed in Version1.3 (SVN) 
Summary0027116: TCustomGroupBox descendants becomes visible even though visible = false
DescriptionUsing a PageContol, a Panel and a BitBtn on a Frame provokes the visibility of all TCustomGrouBox descendants to become visible, although explicitly set to false. At first the boxes are invisible as wanted, but changing page and back triggers the bug.

It seems that all TCustomGroupBox descendants (at least TGroupBox, RadioGroup, CheckGroup)
suffer from the same problem. Even more strange is that in order to provoke the groupbox
to become visible when not wanted, it MUST include a Frame, a PageControl, a Panel and a BitButton.

This bug is only present with the GTK2 widgetset. I have tested with Lazarus 1.2.6 and
latest trunk: Lazarus 1.3 r47043 FPC 2.6.4 x86_64-linux-gtk 2
Additional InformationSee the following video for a demonstration of the attached code:

https://videobin.org/+8cd/b69.html
TagsNo tags attached.
Fixed in Revision47058
LazTarget1.2.8
WidgetsetGTK 2
Attached Files

Activities

Torsten Bonde Christiansen

2014-12-01 15:13

reporter  

project1.lpr (1,273 bytes)

Vojtech Cihak

2014-12-01 15:47

reporter   ~0079538

Last edited: 2014-12-01 16:36

View 2 revisions

I cannot reproduce with Lazarus 1.3 r47047M FPC 2.7.1 x86_64-linux-qt.

I tried to create project as GTk2 and Qt, both work well.

EDIT: My GTk2 version is 2.24.25.

Cedric

2014-12-01 22:28

reporter   ~0079544

Last edited: 2014-12-01 23:23

View 2 revisions

i can reproduce with lazarus 1.3 r47051 FPC 2.6.2 x86_64-linux-gtk2
GTK 2 : Version: 2.24.23-0ubuntu1.1

if i comment the line 2307 of Gtk2WSStdCtrls.pp [gtk_widget_show(FrameBox); ] it's seem to work.

Zeljan Rikalo

2014-12-02 08:31

developer   ~0079552

Last edited: 2014-12-02 08:32

View 2 revisions

Please attach COMPLETE example project.
EDIT: Sorry, just looked into .lpr which contains complete test case.

Torsten Bonde Christiansen

2014-12-02 08:54

reporter   ~0079554

@Cedric

Commenting the line 2307 of Gtk2WSStdCtrls.pp does seem to fix this bug, both in my the test project, but also in my main program.

I have no idea whether this will cause other issues though.

Zeljan Rikalo

2014-12-02 09:57

developer   ~0079565

Please test and close if ok.

Torsten Bonde Christiansen

2014-12-02 10:12

reporter   ~0079567

Works like a charm!

Issue History

Date Modified Username Field Change
2014-12-01 15:13 Torsten Bonde Christiansen New Issue
2014-12-01 15:13 Torsten Bonde Christiansen File Added: project1.lpr
2014-12-01 15:47 Vojtech Cihak Note Added: 0079538
2014-12-01 16:36 Vojtech Cihak Note Edited: 0079538 View Revisions
2014-12-01 22:28 Cedric Note Added: 0079544
2014-12-01 23:23 Cedric Note Edited: 0079544 View Revisions
2014-12-02 08:31 Zeljan Rikalo LazTarget => -
2014-12-02 08:31 Zeljan Rikalo Note Added: 0079552
2014-12-02 08:31 Zeljan Rikalo Assigned To => Zeljan Rikalo
2014-12-02 08:31 Zeljan Rikalo Status new => feedback
2014-12-02 08:32 Zeljan Rikalo Note Edited: 0079552 View Revisions
2014-12-02 08:54 Torsten Bonde Christiansen Note Added: 0079554
2014-12-02 08:54 Torsten Bonde Christiansen Status feedback => assigned
2014-12-02 09:57 Zeljan Rikalo Fixed in Revision => 47058
2014-12-02 09:57 Zeljan Rikalo LazTarget - => 1.2.8
2014-12-02 09:57 Zeljan Rikalo Note Added: 0079565
2014-12-02 09:57 Zeljan Rikalo Status assigned => resolved
2014-12-02 09:57 Zeljan Rikalo Fixed in Version => 1.3 (SVN)
2014-12-02 09:57 Zeljan Rikalo Resolution open => fixed
2014-12-02 09:57 Zeljan Rikalo Target Version => 1.2.8
2014-12-02 10:12 Torsten Bonde Christiansen Note Added: 0079567
2014-12-02 10:12 Torsten Bonde Christiansen Status resolved => closed