View Issue Details

IDProjectCategoryView StatusLast Update
0027130LazarusDebuggerpublic2015-10-27 17:54
ReporterCyraxAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindows OSServer 2008 R2OS Version6.1.7601 (SP1)
Product Version1.3 (SVN)Product Buildr47079 
Target Version1.4Fixed in Version1.5 (SVN) 
Summary0027130: In Evaluate/Modify dialog, pressing Modify button won't change value of evaluated variable.
DescriptionSee summary and Additional Information. Attached sample project for testing.

When trying to change variable value, this appears in Debug Output window:

---
<-gdb-set var ADebugAttach := >
^error,msg="A syntax error in expression, near `'."
(gdb)
---

Only executing command "-gdb-set var ADebugAttach:=false" directly in Debug Output window changes value of the variable.

---
(gdb)
<-gdb-set var ADebugAttach:=false>
=memory-changed,thread-group="i1",addr="0x00432000",len="0x1"
^done
---
Additional InformationLazarus revision 47079
FPC revision 29193
 
FPC make commands:
clean
all
install
OPT=-gw2 -godwarfsets -gl -O- -OoNO -Xs- -Si- -vb -dTEST_WIN32_SEH
COMPILER_OPTIONS=-gw2 -godwarfsets -gl -O- -OoNO -Xs- -Si- -vb -dTEST_WIN32_SEH
INSTALL_PREFIX=F:\free_pascal_and_lazarus\fpc\i386\trunk\binary\fpc_trunk
UPXPROG=echo
IDE=1
REVSTR=29193
 
Lazarus make commands:
clean
all
OPT=-gw2 -godwarfsets -gl -gh -O- -OoNO -Xs- -Si- -vb -dTEST_WIN32_SEH -dHEAPTRC_WINDOW -dDBG_WITH_DEBUGGER_DEBUG
UPXPROG=echo
USESVN2REVISIONINC=0
TagsNo tags attached.
Fixed in Revision47386
LazTarget1.4
WidgetsetWin32/Win64
Attached Files

Activities

Cyrax

2014-12-04 09:08

reporter  

project.zip (1,335 bytes)

Cyrax

2014-12-04 09:13

reporter   ~0079625

Lazarus command line parameters:

--debug-enable=DBG_CMD_ECHO,DBG_STATE,DBG_DATA_MONITORS,DBGMI_QUEUE_DEBUG,DBGMI_TYPE_INFO

Martin Friebe

2015-01-14 02:34

manager   ~0080370

I can not reproduce this.

Did you enter the new value into the (small) edit field (labeled "new value") at the bottom of the dialog before you pressed the "modify" button?

Cyrax

2015-01-14 17:13

reporter   ~0080402

Oh my, no I didn't. I put the new value into "Result:" edit field. It seems that you can modify values in "Result" text box so I assumed that would be appropriate place to put the new value.

New test shows that putting the new value in to "New value" edit field and pressing "Modify" button works.

Thus this bug report is invalid as per se. Please resolve.

Martin Friebe

2015-01-14 19:11

manager   ~0080409

I implemented an error dialog if no new value was entered.

This is currently ok, as empty would only work for strings.But strings can not be modified (the debugged app will crash, because gdb does not play nice with string memory allocated by fpc)

Also added an error, if the modify failed. However no reasons displayed yet.

The eval/modify dialog may need more improvement. Also better feedback, if a value was changed, or failed to do so.

Cyrax

2015-10-27 17:54

reporter   ~0086915

Thanks.

Issue History

Date Modified Username Field Change
2014-12-04 09:08 Cyrax New Issue
2014-12-04 09:08 Cyrax Status new => assigned
2014-12-04 09:08 Cyrax Assigned To => Martin Friebe
2014-12-04 09:08 Cyrax File Added: project.zip
2014-12-04 09:13 Cyrax Note Added: 0079625
2015-01-14 02:34 Martin Friebe LazTarget => -
2015-01-14 02:34 Martin Friebe Note Added: 0080370
2015-01-14 02:34 Martin Friebe Status assigned => feedback
2015-01-14 17:13 Cyrax Note Added: 0080402
2015-01-14 17:13 Cyrax Status feedback => assigned
2015-01-14 19:11 Martin Friebe Fixed in Revision => 47386
2015-01-14 19:11 Martin Friebe LazTarget - => 1.4
2015-01-14 19:11 Martin Friebe Note Added: 0080409
2015-01-14 19:11 Martin Friebe Status assigned => resolved
2015-01-14 19:11 Martin Friebe Fixed in Version => 1.5 (SVN)
2015-01-14 19:11 Martin Friebe Resolution open => fixed
2015-01-14 19:11 Martin Friebe Target Version => 1.4
2015-10-27 17:54 Cyrax Note Added: 0086915
2015-10-27 17:54 Cyrax Status resolved => closed