View Issue Details

IDProjectCategoryView StatusLast Update
0027295LazarusLCLpublic2015-01-15 15:43
ReporterrtnAssigned ToMaxim Ganetsky 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSwindowsOS Version7
Product Version1.2.6Product Build 46529 
Target VersionFixed in Version1.4 
Summary0027295: Arbitrarily appears previously closed Form with the setting property PopupParent
DescriptionSimple project with 2 forms:
Form1 is main form & Form2,
procedure TForm1.Button1Click(Sender: TObject);
begin
  form2.Show;
end;
Form2.PopupParent:=Form1
  
After minimize and maximize application we see previously closed Form2.
see Steps To Reproduce
Steps To Reproduce1.Press Button1 (Form2 is visible)
2.Minimize Application
3.Maximize Application
4.Close Form2
5.Minimize Application
6.Maximize Application.....
we see "closed" Form2 why?.... & close this form we will not be able
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Bart Broersma

2015-01-12 16:31

developer   ~0080319

Please do not attache exectables to the bugreport.
Please attach a compileable sample project (sources only: lpr, lpi, lfm, pas) demontsrating the issue.

rtn

2015-01-12 16:58

reporter   ~0080321

sorry, now i upload project folder without exe

rtn

2015-01-12 17:05

reporter  

test.zip (283,284 bytes)

Bart Broersma

2015-01-13 12:20

developer   ~0080336

I cannot reproduce (Lazarus 1.5 r47338 FPC 2.6.4 i386-win32-win32/win64).

rtn

2015-01-15 07:14

reporter   ~0080422

Yes, in the last svn version this problem is absent!

Maxim Ganetsky

2015-01-15 13:45

developer   ~0080424

Fixed in the meantime according to reporter.

Please close if OK.

Issue History

Date Modified Username Field Change
2015-01-12 16:01 rtn New Issue
2015-01-12 16:02 rtn File Added: project1.exe
2015-01-12 16:30 Bart Broersma File Deleted: project1.exe
2015-01-12 16:31 Bart Broersma Note Added: 0080319
2015-01-12 16:32 Bart Broersma LazTarget => -
2015-01-12 16:32 Bart Broersma Status new => feedback
2015-01-12 16:58 rtn Note Added: 0080321
2015-01-12 16:58 rtn Status feedback => new
2015-01-12 17:05 rtn File Added: test.zip
2015-01-13 12:20 Bart Broersma Note Added: 0080336
2015-01-15 07:14 rtn Note Added: 0080422
2015-01-15 13:45 Maxim Ganetsky Note Added: 0080424
2015-01-15 13:45 Maxim Ganetsky Status new => resolved
2015-01-15 13:45 Maxim Ganetsky Fixed in Version => 1.4
2015-01-15 13:45 Maxim Ganetsky Resolution open => fixed
2015-01-15 13:45 Maxim Ganetsky Assigned To => Maxim Ganetsky
2015-01-15 15:43 rtn Status resolved => closed