View Issue Details

IDProjectCategoryView StatusLast Update
0027456LazarusIDEpublic2015-02-17 01:12
ReporterHoward Page-Clark Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3 (SVN) 
Summary0027456: On Windows Object Inspector menuitem shortcut editor combobox lists invalid shortcuts
DescriptionWhen you edit a shortcut for a menuitem on Windows using the Object Inspector the editor combo dropdown lists Meta+A, Meta+B, etc. along with correct items.
Steps To ReproduceOn Windows, add a shortcut to a menu's menuitem via the Object Inspector.
Additional InformationI think changing the propedits.pp procedure at line 4937 to the following will resolve the issue. I have not submitted a patch, however, since this may not be correct, or may have other effects I am not aware of.

procedure TShortCutPropertyEditor.GetValues(Proc: TGetStrProc);
var
  I: Integer;
begin
  Proc(oisNone);
  {$IfDef Darwin}
    for I := 1 to High(ShortCuts) do Proc(ShortCutToText(ShortCuts[I]));
  {$Else}
    for I := 1 to 26 do Proc(ShortCutToText(ShortCuts[I]));
    for I := 53 to High(ShortCuts) do Proc(ShortCutToText(ShortCuts[I]));
  {$EndIf}
end;
TagsNo tags attached.
Fixed in Revisionr47850
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Juha Manninen

2015-02-17 01:12

developer   ~0081158

Applied, thanks.

Issue History

Date Modified Username Field Change
2015-02-12 22:45 Howard Page-Clark New Issue
2015-02-17 01:06 Juha Manninen Assigned To => Juha Manninen
2015-02-17 01:06 Juha Manninen Status new => assigned
2015-02-17 01:12 Juha Manninen Fixed in Revision => r47850
2015-02-17 01:12 Juha Manninen LazTarget => -
2015-02-17 01:12 Juha Manninen Note Added: 0081158
2015-02-17 01:12 Juha Manninen Status assigned => resolved
2015-02-17 01:12 Juha Manninen Resolution open => fixed