View Issue Details

IDProjectCategoryView StatusLast Update
0027541LazarusIDEpublic2015-03-01 00:54
ReporterwpAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5 (SVN)Product Build 
Target Version1.6Fixed in Version1.5 (SVN) 
Summary0027541: Double-click in modal file dialog is passed to underlying source editor
DescriptionHere's another regression that must have been introduced into trunk recently:

Load any project, select "File" / "Open" to show the dialog for file selection. Select any file by double-clicking. But before doing this, drag the dialog to a position such that the gutter of the IDE source editor is directly underneath the file to be double-clicked. After the double-click a break-point is set in the source window although the file dialog is modal.

Obviously the double-click into the modal file dialog window is passed to the underlying editor window.

I checked with 1.4RC1. Here the behavior is normal, i.e. no break-point is created in the same situation.
TagsNo tags attached.
Fixed in Revision48050
LazTarget1.6
WidgetsetWin32/Win64
Attached Files

Activities

Zeljan Rikalo

2015-02-26 11:45

developer   ~0081449

Added 1.4 as target since this is regression.

Juha Manninen

2015-02-26 12:43

developer   ~0081450

Last edited: 2015-02-26 13:48

View 5 revisions

Did I cause this? Which revision?

> Added 1.4 as target since this is regression.
Zeljko, according to wp the regression is not in 1.4 branch. It is only in trunk.

[Edit] I cannot reproduce. Can anybody else?
I also don't remember any commits recently that could affect dbl-clicks on Windows. Besides the open dialog is a standard Windows dialog, not directly controlled by Lazarus.

I think you have some configuration problem there. No idea what it could be more exactly.

wp

2015-02-26 21:47

developer   ~0081462

Last edited: 2015-02-26 21:47

View 2 revisions

Sorry for selecting "Reproducibilty always" too hastily. However, after some investigation, now I really can reproduce it "always": In revision 47905 a new option "Editor" / "Mouse" / "Gutter" / "extended" was introduced which modifies a mouse click in the gutter of the editor such that the entire line can be selected. If this option is turned on the bug is always present. If it is off (as in RC1 where it did not yet exist, and as in my two other trunk versions that I have access to) the behavior is normal.

Zeljan Rikalo

2015-02-27 09:00

developer   ~0081474

Target setted up to 1.6, this option is not in 1.4

Martin Friebe

2015-02-28 17:06

manager   ~0081510

Please test, and close if ok.

The option is also present in 1.4 (and even 1.2). Only it defaults to off.

However due to the huge amount of ways the mouse can be configured and used, it is impossible to say if the patch has side effects or not.
Therefore it must not be merged.

wp

2015-03-01 00:54

developer   ~0081521

Perfect, thank you.

Issue History

Date Modified Username Field Change
2015-02-25 22:53 wp New Issue
2015-02-25 22:54 wp Description Updated View Revisions
2015-02-26 11:45 Zeljan Rikalo Assigned To => Juha Manninen
2015-02-26 11:45 Zeljan Rikalo Status new => assigned
2015-02-26 11:45 Zeljan Rikalo LazTarget - => 1.4
2015-02-26 11:45 Zeljan Rikalo Note Added: 0081449
2015-02-26 11:45 Zeljan Rikalo Target Version => 1.4RC2
2015-02-26 12:43 Juha Manninen Note Added: 0081450
2015-02-26 12:43 Juha Manninen Status assigned => feedback
2015-02-26 13:45 Juha Manninen Note Edited: 0081450 View Revisions
2015-02-26 13:45 Juha Manninen Note Edited: 0081450 View Revisions
2015-02-26 13:46 Juha Manninen Note Edited: 0081450 View Revisions
2015-02-26 13:48 Juha Manninen Note Edited: 0081450 View Revisions
2015-02-26 21:47 wp Note Added: 0081462
2015-02-26 21:47 wp Status feedback => assigned
2015-02-26 21:47 wp Note Edited: 0081462 View Revisions
2015-02-27 00:53 Juha Manninen Assigned To Juha Manninen => Martin Friebe
2015-02-27 09:00 Zeljan Rikalo LazTarget 1.4 => 1.6
2015-02-27 09:00 Zeljan Rikalo Note Added: 0081474
2015-02-27 09:00 Zeljan Rikalo Target Version 1.4RC2 =>
2015-02-28 17:06 Martin Friebe Fixed in Revision => 48050
2015-02-28 17:06 Martin Friebe Note Added: 0081510
2015-02-28 17:06 Martin Friebe Status assigned => resolved
2015-02-28 17:06 Martin Friebe Fixed in Version => 1.5 (SVN)
2015-02-28 17:06 Martin Friebe Resolution open => fixed
2015-02-28 17:06 Martin Friebe Target Version => 1.6
2015-03-01 00:54 wp Note Added: 0081521
2015-03-01 00:54 wp Status resolved => closed