View Issue Details

IDProjectCategoryView StatusLast Update
0027546LazarusIDEpublic2015-03-02 17:00
Reportergilles58Assigned ToMaxim Ganetsky 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.4RC1Product Build 
Target VersionFixed in Version1.4 
Summary0027546: Translation for lazaruside.fr.po
DescriptionAs for LCL, I've translated 92% of lazaruside.fr.po : new items and erroneous translations. Hope it will be useful.
I keep on working on this file but already give it to the communauty.
Best regards
TagsNo tags attached.
Fixed in Revision48025
LazTarget-
Widgetset
Attached Files

Activities

gilles58

2015-02-26 15:50

reporter  

lazaruside.fr.po (651,424 bytes)

Maxim Ganetsky

2015-02-26 23:49

developer   ~0081466

Last edited: 2015-02-27 00:06

View 2 revisions

Applied, thanks.

It seems that you edit PO files manually (I noticed several errors and fixed them). Don't do this. Use programs like poEdit (www.poedit.net) or Lokalize.

See <lazarus dir>\languages\README.txt for details on translation process.

BTW I noticed "Compilationdu paquet %s" string in your translation. Is it a typo?

gilles58

2015-02-27 09:04

reporter   ~0081475

Last edited: 2015-02-27 09:04

View 2 revisions

Yes, it's a typo... Lots of items contain(ed) typos like this, sometimes for a long time... I'll do my best to read all items again but the file is quite a big one. As mentioned in my post, job isn't done : the file is only (much) better than it was !

I extracted the po file from a fresh SVN po file, but while working a new po file was posted on SVN with new items. I am not used with such tools : i'll look for poEdit... On the forum somebody told me to use pochecker : the problem is it returned no errors.

Issue History

Date Modified Username Field Change
2015-02-26 15:48 gilles58 New Issue
2015-02-26 15:50 gilles58 File Added: lazaruside.fr.po
2015-02-26 22:36 Maxim Ganetsky Assigned To => Maxim Ganetsky
2015-02-26 22:36 Maxim Ganetsky Status new => assigned
2015-02-26 23:49 Maxim Ganetsky Fixed in Revision => 48025
2015-02-26 23:49 Maxim Ganetsky LazTarget => -
2015-02-26 23:49 Maxim Ganetsky Note Added: 0081466
2015-02-26 23:49 Maxim Ganetsky Status assigned => resolved
2015-02-26 23:49 Maxim Ganetsky Fixed in Version => 1.4
2015-02-26 23:49 Maxim Ganetsky Resolution open => fixed
2015-02-27 00:06 Maxim Ganetsky Note Edited: 0081466 View Revisions
2015-02-27 09:04 gilles58 Note Added: 0081475
2015-02-27 09:04 gilles58 Note Edited: 0081475 View Revisions
2015-03-02 17:00 gilles58 Status resolved => closed