View Issue Details

IDProjectCategoryView StatusLast Update
0027565FPCCompilerpublic2015-03-15 17:27
ReporterMaciej Izak Assigned ToFlorian  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version3.1.1 
Fixed in Version3.1.1 
Summary0027565: Generics Internal error 2010021405 for Unix 64 bits (Generics.Collections)
DescriptionProblem on Unix 64bits (Linux, FreeBSD etc) with build of Generics.Collections library (related to 0027206)

generics.collections.pas(106,42) Fatal: Internal error 2010021405

on Windows 32 and 64bits, Wince, Arm-Linux and Unix 32bits (Linux,FreeBSD etc ) all is OK

=== minimal code to generate this error ===

program p2010021405;

{$mode delphi}{$H+}

type
  TEnumerator<T> = class
  public
    function DoGetCurrent: T; virtual; abstract;

    property Current: T read DoGetCurrent; // Error: Internal error 2010021405
  end;

  TPair<TKey, TValue> = record
  public
    Key: TKey;
    Value: TValue;
  end;

  TA<TKey, TValue> = class
  public type
    TDictionaryPair = TPair<TKey, TValue>;
  public
    E: TEnumerator<TDictionaryPair>;
  end;

  TB<TKey, TValue> = class(TA<TKey, TValue>)
  public type
    TItem = record
      F: UInt32;
    end;

    TC = class(TA<TKey, TItem>);
  end;

begin
end.
TagsNo tags attached.
Fixed in Revision30239
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0027658 closedFlorian Internal error 2010021405 
related to 0027206 resolvedSven Barth [Patch] Christmas gift by FreeSparta : Generics.Collections 

Activities

Maciej Izak

2015-02-28 13:48

reporter  

p2010021405.lpr (634 bytes)

Maciej Izak

2015-02-28 22:07

reporter   ~0081516

Last edited: 2015-02-28 22:09

View 3 revisions

Looks like classify_argument function in x86_64\cpupara.pas don't work correctly with generics types. Is the field "typ" (in the class symtype.tdef) always equal to undefineddef for generics types?

Library works by accident in Win64 because calling convention is handled in other way than in Unix platforms...

Maciej Izak

2015-03-14 11:38

reporter   ~0081938

Can someone add relationship to 0027206?

Issue History

Date Modified Username Field Change
2015-02-28 13:48 Maciej Izak New Issue
2015-02-28 13:48 Maciej Izak File Added: p2010021405.lpr
2015-02-28 22:07 Maciej Izak Note Added: 0081516
2015-02-28 22:07 Maciej Izak Note Edited: 0081516 View Revisions
2015-02-28 22:09 Maciej Izak Note Edited: 0081516 View Revisions
2015-03-14 11:38 Maciej Izak Note Added: 0081938
2015-03-14 11:47 Marco van de Voort Relationship added related to 0027206
2015-03-15 17:27 Florian Relationship added duplicate of 0027658
2015-03-15 17:27 Florian Fixed in Revision => 30239
2015-03-15 17:27 Florian Status new => resolved
2015-03-15 17:27 Florian Fixed in Version => 3.1.1
2015-03-15 17:27 Florian Resolution open => duplicate
2015-03-15 17:27 Florian Assigned To => Florian