View Issue Details

IDProjectCategoryView StatusLast Update
0027658FPCCompilerpublic2015-03-15 18:28
ReporterAndrey Zubarev Assigned ToFlorian  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformLinux x86_64OSkubuntu 
Product Version3.1.1 
Fixed in Version3.1.1 
Summary0027658: Internal error 2010021405
DescriptionThis sample work on windows with trunk fpc (x86), but not work on linux (x86_64)
{$MODE OBJFPC}
program Project1;

uses gmap;

type

generic TMyMap <TKey, TValue, TCompare> = class(specialize TMap<TKey, TValue, TCompare>)
end;
generic TMyCounter <TKey, TCompare> = class(specialize TMyMap<TKey, SizeUInt, TCompare>)
end;

begin
end.

output:
Hint: (11030) Start of reading config file /etc/fpc.cfg
Hint: (11031) End of reading config file /etc/fpc.cfg
Free Pascal Compiler version 3.1.1 [2015/03/12] for x86_64
Copyright (c) 1993-2015 by Florian Klaempfl and others
(1002) Target OS: Linux for x86-64
(3104) Compiling /home/zamtmn/tmp/project1.lpr
/home/zamtmn/tmp/gset.pp(30,33) Fatal: Internal error 2010021405
Fatal: (1018) Compilation aborted
TagsNo tags attached.
Fixed in Revision30239
FPCOldBugId
FPCTarget
Attached Files

Relationships

has duplicate 0027565 resolvedFlorian Generics Internal error 2010021405 for Unix 64 bits (Generics.Collections) 

Activities

Cyrax

2015-03-13 00:33

reporter   ~0081891

Last edited: 2015-03-13 00:36

View 4 revisions

Example program compiles with Windows FPC trunk 64-bit version.

EDIT: What command line options you did use? Mine was : -MObjFPC -Scghi -gw2 -godwarfsets -gl -l -vewnhibq -Filib\x86_64-win64-win32 -Fusrc\forms -Fu. -FUlib\x86_64-win64-win32\ -FEbin\x86_64-win64-win32\

Maciej Izak

2015-03-13 03:07

reporter   ~0081898

Same "Internal error 2010021405" for 0027565 . Compiles with Windows 64 because Windows version don't use classify_argument function (x86_64\cpupara.pas)

Andrey Zubarev

2015-03-13 08:06

reporter   ~0081900

>>What command line options you did use?
-MObjFPC
-Scghi
-Cg
-O1
-g
-gl
-l
-vewnhibq
-Fi/home/zamtmn/hdd/bug/lib/x86_64-linux
-Fu/home/zamtmn/hdd/bug/
-FU/home/zamtmn/hdd/bug/lib/x86_64-linux/

Andrey Zubarev

2015-03-13 10:41

reporter   ~0081909

test on win7x64 with
>>Free Pascal Compiler version 3.1.1 [2015/02/20] for x86_64
error not present, all works

Andrey Zubarev

2015-03-15 18:28

reporter   ~0081997

Thanks!

Issue History

Date Modified Username Field Change
2015-03-12 20:03 Andrey Zubarev New Issue
2015-03-13 00:33 Cyrax Note Added: 0081891
2015-03-13 00:34 Cyrax Note Edited: 0081891 View Revisions
2015-03-13 00:35 Cyrax Note Edited: 0081891 View Revisions
2015-03-13 00:36 Cyrax Note Edited: 0081891 View Revisions
2015-03-13 03:07 Maciej Izak Note Added: 0081898
2015-03-13 08:06 Andrey Zubarev Note Added: 0081900
2015-03-13 10:41 Andrey Zubarev Note Added: 0081909
2015-03-15 17:20 Florian Fixed in Revision => 30239
2015-03-15 17:20 Florian Status new => resolved
2015-03-15 17:20 Florian Fixed in Version => 3.1.1
2015-03-15 17:20 Florian Resolution open => fixed
2015-03-15 17:20 Florian Assigned To => Florian
2015-03-15 17:27 Florian Relationship added has duplicate 0027565
2015-03-15 18:28 Andrey Zubarev Note Added: 0081997
2015-03-15 18:28 Andrey Zubarev Status resolved => closed