View Issue Details

IDProjectCategoryView StatusLast Update
0027693FPCFCLpublic2015-09-14 13:31
Reporterfreeman35 Assigned ToMarco van de Voort  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platformx64OSosx 
Product Version3.1.1 
Summary0027693: sockets.pp(20,5) Error: include file not found "osdefs.inc"
Description/opt/freepascal/3.1.1/packages/rtl-extra/src/unix/sockets.pp

In lazarus TLTCPComponent compileted and installed without error. when try code complied I get this error and project not compile.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Activities

Jonas Maebe

2015-03-19 16:54

manager   ~0082110

That's a configuration problem in your lazarus. Please ask for help on the fora or mailing lists.

Michael Van Canneyt

2015-03-21 10:30

administrator   ~0082155

This is not a lazarus issue. The osdefs.inc files are in the RTL directory.
the sockets are in the rtl-extra directory.

When compiling rtl-extra, the compiler should not look for files in the rtl directory. Either the files are duplicated, or some other option must be found

(Personally, I think these files should not exist to begin with)

Jonas Maebe

2015-03-21 11:05

manager   ~0082157

The error he gets means that he's including the FPC source directories in his search path while building a Lazarus component. This means his configuration is wrong, as only the FPC ppu's should be in the search path. Building programs/units with the FPC unit sources in the search path has always caused problems, and probably always will (unless perhaps if we would make every possible source file name unique in the entire source tree, but I don't see the use of that).

Michael Van Canneyt

2015-03-21 11:21

administrator   ~0082160

Hm.

@Jonas:
When I first checked, find didn't report any osdefs.inc.
Following your remark, I tried again, and indeed, these files have been duplicated. I must have made a typo in my first attempt.

Not my favourite solution, but indeed the problem is a user problem.

Closing again.

Marco van de Voort

2015-03-22 11:28

manager   ~0082182

(it's the same as in Delphi, the compiler searchpath should only find ppu/dcu's, and the browse path (for debugging, codetools, etc) should have the sources)

Issue History

Date Modified Username Field Change
2015-03-19 15:16 freeman35 New Issue
2015-03-19 16:54 Jonas Maebe Note Added: 0082110
2015-03-19 16:54 Jonas Maebe Status new => resolved
2015-03-19 16:54 Jonas Maebe Resolution open => no change required
2015-03-19 16:54 Jonas Maebe Assigned To => Jonas Maebe
2015-03-21 10:28 Michael Van Canneyt Assigned To Jonas Maebe => Marco van de Voort
2015-03-21 10:28 Michael Van Canneyt Status resolved => assigned
2015-03-21 10:30 Michael Van Canneyt Note Added: 0082155
2015-03-21 10:30 Michael Van Canneyt Status assigned => new
2015-03-21 11:05 Jonas Maebe Note Added: 0082157
2015-03-21 11:21 Michael Van Canneyt Note Added: 0082160
2015-03-21 11:21 Michael Van Canneyt Status new => resolved
2015-03-22 11:28 Marco van de Voort Note Added: 0082182
2015-09-14 13:31 freeman35 Status resolved => closed