View Issue Details

IDProjectCategoryView StatusLast Update
0027696LazarusLCLpublic2015-05-30 00:51
ReportersnorkelAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformQTOSNetrunner KDE 64bitOS Version2014.09
Product Version1.4RC2Product Build 
Target Version1.4Fixed in Version1.5 (SVN) 
Summary0027696: Tlistview view on QT only will not show text if icon is assigned from imagelist to tlistitem.
DescriptionWhen using a imagelist with a tlistview the tlistitem will not show text after a image index is set.

Works fine on all other widget sets, just not QT.

 
Steps To Reproduceprocedure TMainDatamod.addmsg(themsg:string;icon:TmsgIconType);
var
   datestr:string;
   aitem:TListItem;
begin
      datestr:=formatdatetime('mm/dd/yyyy HH:MM:SS AM/PM',now);
      aitem:= mainform.messages_lv.Items.Add;
      aitem.ImageIndex:=integer(icon);
      aitem.Caption:=format('%-32s %s',[datestr,themsg]);
      mainform.messages_lv.Items.Item[mainform.messages_lv.Items.Count-1].MakeVisible(false);
end;
TagsNo tags attached.
Fixed in Revision48475
LazTarget1.4
WidgetsetQT
Attached Files

Relationships

related to 0027740 closedZeljan Rikalo In procedure list, when try searching I get error 
related to 0028212 closedZeljan Rikalo TreeView item width set to -1 and do not show 

Activities

Zeljan Rikalo

2015-03-20 08:26

developer   ~0082118

Please attach example project.

Zeljan Rikalo

2015-03-20 20:58

developer   ~0082149

Cannot reproduce this one.

snorkel

2015-03-23 19:10

reporter   ~0082226

ok, going to make a sample project.

snorkel

2015-03-23 19:26

reporter   ~0082231

I made a sample project that shows error.
Widget set must be QT.
I am also attaching a screen shot of me running the sample project on 1.4 RC2
which shows the results right after clicking the button.

snorkel

2015-03-23 19:26

reporter  

snapshot3.png (183,287 bytes)
snapshot3.png (183,287 bytes)

snorkel

2015-03-23 19:26

reporter   ~0082232

Notice in the first screen shot only the image is displayed.

snorkel

2015-03-23 19:28

reporter  

sample_proj.zip (132,205 bytes)

Zeljan Rikalo

2015-03-23 20:34

developer   ~0082236

It is possible that such error exists on RC2, but it's fixed in trunk, so you should test with trunk somehow.

snorkel

2015-03-23 20:45

reporter   ~0082239

ok, checking out a copy of the trunk version now.

snorkel

2015-03-23 21:06

reporter   ~0082242

Does not work with trunk either.
See screen shot of me running sample project on trunk.

snorkel

2015-03-23 21:07

reporter  

snapshot4.png (299,754 bytes)

snorkel

2015-03-23 21:08

reporter   ~0082243

FYI,
I have the trunk IDE compiled as GTK2 and the project is set to build as QT.

Zeljan Rikalo

2015-03-23 21:10

developer   ~0082244

Yes, I can reproduce with your example. Problem is TListColumn.AutoSize=true

snorkel

2015-03-23 21:17

reporter   ~0082245

I just found it on my own as well, it is indeed the column autosize.
Autosize has to be false or it does not work on QT.

Not sure if it's still considered a bug, but it should behave the same on all the widget sets right?

Zeljan Rikalo

2015-03-23 21:51

developer   ~0082246

Workaround if U use only one column: set column autosize to false and in listView set AutoWidthLastCol to true. It smells like Qt bug, since QHeader_setResizeMode(column, stretch) works but QHeader_setResizeMode(column, autosize) does not for some reason.

Zeljan Rikalo

2015-03-24 10:31

developer   ~0082270

Fixed. Please test and close if ok.

tcaduto

2015-04-16 18:51

reporter   ~0082964

works great now in RC3

Issue History

Date Modified Username Field Change
2015-03-19 23:09 snorkel New Issue
2015-03-20 08:26 Zeljan Rikalo LazTarget => -
2015-03-20 08:26 Zeljan Rikalo Note Added: 0082118
2015-03-20 08:26 Zeljan Rikalo Assigned To => Zeljan Rikalo
2015-03-20 08:26 Zeljan Rikalo Status new => feedback
2015-03-20 20:58 Zeljan Rikalo Note Added: 0082149
2015-03-23 19:10 snorkel Note Added: 0082226
2015-03-23 19:10 snorkel Status feedback => assigned
2015-03-23 19:26 snorkel Note Added: 0082231
2015-03-23 19:26 snorkel File Added: snapshot3.png
2015-03-23 19:26 snorkel Note Added: 0082232
2015-03-23 19:28 snorkel File Added: sample_proj.zip
2015-03-23 20:34 Zeljan Rikalo Note Added: 0082236
2015-03-23 20:45 snorkel Note Added: 0082239
2015-03-23 21:06 snorkel Note Added: 0082242
2015-03-23 21:07 snorkel File Added: snapshot4.png
2015-03-23 21:08 snorkel Note Added: 0082243
2015-03-23 21:10 Zeljan Rikalo Note Added: 0082244
2015-03-23 21:10 Zeljan Rikalo Status assigned => confirmed
2015-03-23 21:17 snorkel Note Added: 0082245
2015-03-23 21:51 Zeljan Rikalo Note Added: 0082246
2015-03-24 10:31 Zeljan Rikalo Fixed in Revision => 48475
2015-03-24 10:31 Zeljan Rikalo LazTarget - => 1.4
2015-03-24 10:31 Zeljan Rikalo Note Added: 0082270
2015-03-24 10:31 Zeljan Rikalo Status confirmed => resolved
2015-03-24 10:31 Zeljan Rikalo Fixed in Version => 1.5 (SVN)
2015-03-24 10:31 Zeljan Rikalo Resolution open => fixed
2015-03-24 10:31 Zeljan Rikalo Target Version => 1.4
2015-03-26 14:08 Juha Manninen Relationship added related to 0027740
2015-04-16 18:51 tcaduto Note Added: 0082964
2015-05-30 00:51 Juha Manninen Relationship added related to 0028212