View Issue Details

IDProjectCategoryView StatusLast Update
0027703LazarusIDEpublic2015-05-16 05:31
ReporterTony WhymanAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAMD64OSLimux MintOS Version17
Product Version1.4RC2Product Build 
Target Version1.6Fixed in Version1.5 (SVN) 
Summary0027703: Problem Editing with TDBGridColumn Title.Caption Editor
DescriptionWhen editing a Grid Column Title Caption in the Object Inspector:

(a) If all text selected then pressing a key appends/prepends rather than replacing

(b) Place cursor at end of line and then press backspace multiple times. When all characters deleted, the original text is restored!
Steps To ReproduceDrop a DBGrid on to a form, double click to open column editor.

Add a column

Then try editing the Column's Title.Caption in the Object Inspector as above. No need to add a datasource. Do not click on elipses to open dialog editor. This is not where the problem is. The problem is when editing in situ in the Object Inspector.
Additional InformationThis appears to be a regression from 1.2.6
TagsNo tags attached.
Fixed in Revision49040
LazTarget1.6
WidgetsetGTK 2
Attached Files

Relationships

related to 0025116 closedJesus Reyes StringGrid.Columns[].Title.Caption not set empty value 

Activities

Jesus Reyes

2015-05-16 05:31

developer   ~0083634

Please test.

Issue History

Date Modified Username Field Change
2015-03-20 15:11 Tony Whyman New Issue
2015-04-01 19:39 Jesus Reyes Assigned To => Jesus Reyes
2015-04-01 19:39 Jesus Reyes Status new => assigned
2015-05-15 22:04 Jesus Reyes Relationship added related to 0025116
2015-05-16 05:31 Jesus Reyes Fixed in Revision => 49040
2015-05-16 05:31 Jesus Reyes LazTarget => 1.6
2015-05-16 05:31 Jesus Reyes Note Added: 0083634
2015-05-16 05:31 Jesus Reyes Status assigned => resolved
2015-05-16 05:31 Jesus Reyes Fixed in Version => 1.5 (SVN)
2015-05-16 05:31 Jesus Reyes Resolution open => fixed
2015-05-16 05:31 Jesus Reyes Target Version => 1.6