View Issue Details

IDProjectCategoryView StatusLast Update
0027714LazarusIDEpublic2015-12-06 10:02
ReportermalcomeAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows 7 32bit JapaneseOS Version
Product Version1.4RC2Product Build 
Target Version1.4Fixed in Version1.5 (SVN) 
Summary0027714: Source Editor(TSynEdit) input problem with IMM. "System" draws horiz lines
DescriptionI checked "IME handled by System". See new image checked.png.
Drawing Horz Line in Source Editor.
Is this normal?
TagsNo tags attached.
Fixed in Revision48470
LazTarget1.6
WidgetsetWin32/Win64
Attached Files

Relationships

has duplicate 0027712 closedMartin Friebe Source Editor(TSynEdit) input problem with IMM. 

Activities

2015-03-23 09:37

 

checked.png (123,194 bytes)
checked.png (123,194 bytes)

Martin Friebe

2015-03-23 13:28

manager   ~0082205

I can not reproduce the horizontal lines. So I need more info on that.

1) Can you take an image of SynEdit "IME handled by system", while the IME is active?

2) When the lines are visible: Move any other window over SynEdit, are the lines still there?

3) When the lines are visible: Resize the Editor, are the lines still there?


Please attach your editoroptions.xml.
C:\Users\__YOUR_NAME__\AppData\Local\lazarus\editoroptions.xml

malcome

2015-03-23 22:21

reporter  

editoroptions.xml (665 bytes)

malcome

2015-03-23 22:27

reporter  

handledbysystem1.png (11,609 bytes)
handledbysystem1.png (11,609 bytes)

malcome

2015-03-23 22:31

reporter   ~0082248

1) attached.(handledbysystem1.png)
2) Yes, the lines still there.
3) Yes, the lines still there.

>>Please attach your editoroptions.xml.
attached.

malcome

2015-03-24 00:01

reporter   ~0082252

Fixed in v1.5 r48465.

Martin Friebe

2015-03-24 00:05

manager   ~0082253

Please test with r48470 (1.5)

I am still unable to reproduce, but I found some of the markup modules created for the default IME (none system) were not removed, and left in a faulty state.

This was most likely the cause.

malcome

2015-03-24 10:55

reporter   ~0082272

no prob in r48472.

Issue History

Date Modified Username Field Change
2015-03-23 13:27 Martin Friebe New Issue
2015-03-23 13:27 Martin Friebe Status new => assigned
2015-03-23 13:27 Martin Friebe Assigned To => Martin Friebe
2015-03-23 13:27 Martin Friebe Issue generated from: 0027712
2015-03-23 13:27 Martin Friebe Relationship added has duplicate 0027712
2015-03-23 13:27 Martin Friebe File Deleted: img1.png
2015-03-23 13:27 Martin Friebe File Deleted: img2.png
2015-03-23 13:27 Martin Friebe File Deleted: img3.png
2015-03-23 13:27 Martin Friebe File Deleted: img4.png
2015-03-23 13:27 Martin Friebe File Deleted: img5.png
2015-03-23 13:27 Martin Friebe File Deleted: img6.png
2015-03-23 13:28 Martin Friebe Note Added: 0082205
2015-03-23 15:53 Martin Friebe Status assigned => feedback
2015-03-23 16:02 Martin Friebe Reporter Martin Friebe => malcome
2015-03-23 22:21 malcome File Added: editoroptions.xml
2015-03-23 22:27 malcome File Added: handledbysystem1.png
2015-03-23 22:31 malcome Note Added: 0082248
2015-03-23 22:31 malcome Status feedback => assigned
2015-03-24 00:01 malcome Note Added: 0082252
2015-03-24 00:05 Martin Friebe Note Added: 0082253
2015-03-24 00:05 Martin Friebe Status assigned => feedback
2015-03-24 10:55 malcome Note Added: 0082272
2015-03-24 10:55 malcome Status feedback => assigned
2015-03-24 16:03 Martin Friebe Fixed in Revision => 48470
2015-03-24 16:03 Martin Friebe LazTarget - => 1.6
2015-03-24 16:03 Martin Friebe Status assigned => resolved
2015-03-24 16:03 Martin Friebe Fixed in Version => 1.5 (SVN)
2015-03-24 16:03 Martin Friebe Resolution open => fixed
2015-03-24 16:03 Martin Friebe Target Version => 1.4
2015-12-06 10:02 malcome Status resolved => closed