View Issue Details

IDProjectCategoryView StatusLast Update
0027748LazarusIDEpublic2015-03-30 23:20
ReporterC WesternAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSfedoraOS Version
Product Version1.5 (SVN)Product Build 
Target Version1.4Fixed in Version1.5 (SVN) 
Summary0027748: Crash in syneditmarkupifdef
DescriptionCrash on closing project options dialog:

TApplication.HandleException not found ifdef LogX=25 FldAct=[sfaClose,sfaMultiLine,sfaMarkup,sfaCloseFold] Line=6 Txt= {$ifdef mswindows} windows, {$endif} messages, sysutils, classes, (syneditmarkupifdef.pp, line 2743)
  Stack trace:
  $0000000000E852F5 line 3044 of syneditmarkupifdef.pp
  $0000000000E8A7D0 line 4084 of syneditmarkupifdef.pp
  $0000000000FD000F line 1589 of sourcesyneditor.pas
  $0000000000AB9EB7 line 5592 of sourceeditor.pp
  $0000000000AB5138 line 4333 of sourceeditor.pp
  $0000000000AC5653 line 8186 of sourceeditor.pp
  $0000000000AC94DB line 9450 of sourceeditor.pp
  $00000000004AF935 line 5056 of main.pp
  $000000000049793E line 815 of ideoptionsintf.pas
  $0000000000B97180 line 473 of ideoptionsdlg.pas
  $00000000004AEBFF line 4743 of main.pp
  $00000000004AC224 line 4162 of main.pp
  $00000000009CB94A line 681 of projectinspector.pas
  $00000000006A4424 line 2724 of include/control.inc
  $00000000006FE749 line 789 of include/toolbutton.inc
  $00000000006FBB77 line 133 of include/toolbutton.inc
  $00000000006A3388 line 2169 of include/control.inc
TagsNo tags attached.
Fixed in Revision48532
LazTarget1.4
WidgetsetGTK 2
Attached Files

Activities

Martin Friebe

2015-03-29 18:06

manager   ~0082429

Can you reproduce the issue?

If so, can you make the source, and steps needed to reproduce available?

Martin Friebe

2015-03-29 18:30

manager   ~0082430

It appears to have happened when you closed the project options.

If it happens again:

Ensure the editor in which the error happened is active (only needed if there are multiple source edit windows).

Then please open:
"View" > "IDE Internals" > "Codetool node info"

Copy the content, of each tab, and save each to a file. Attach the 3 files.

Post the new error message as well, in case it contains different coordinates.

C Western

2015-03-29 18:41

reporter   ~0082431

Repeating: (Closing tools options also seems to trigger this).
View, IDE Internals does not show a codetools option (Current SVN)


TApplication.HandleException not found ifdef LogX=25 FldAct=[sfaClose,sfaMultiLine,sfaMarkup,sfaCloseFold] Line=6 Txt= {$ifdef mswindows} windows, {$endif} messages, sysutils, classes, (syneditmarkupifdef.pp, line 2743)
  Stack trace:
  $0000000000E853B5 line 3044 of syneditmarkupifdef.pp
  $0000000000E8A890 line 4084 of syneditmarkupifdef.pp
  $0000000000FD029F line 1589 of sourcesyneditor.pas
  $0000000000AB9F77 line 5592 of sourceeditor.pp
  $0000000000AB51F8 line 4333 of sourceeditor.pp
  $0000000000AC5713 line 8186 of sourceeditor.pp
  $0000000000AC959B line 9450 of sourceeditor.pp
  $00000000004AF935 line 5056 of main.pp
  $000000000049793E line 815 of ideoptionsintf.pas
  $0000000000B97240 line 473 of ideoptionsdlg.pas
  $00000000004AEBFF line 4743 of main.pp
  $00000000004AC224 line 4162 of main.pp
  $00000000009CBA0A line 681 of projectinspector.pas
  $00000000006A44B4 line 2724 of include/control.inc
  $00000000006FE7D9 line 789 of include/toolbutton.inc
  $00000000006FBC07 line 133 of include/toolbutton.inc
  $00000000006A3418 line 2169 of include/control.inc

Martin Friebe

2015-03-29 19:30

manager   ~0082433

"View, IDE Internals does not show a codetools option (Current SVN)"

Possible you need to install the cody package.
Otherwise I have to ask around how to get it.

Which unit is that code in. I can copy that line to units in my code, and the error does not happen.

Are there tabs on that line?

C Western

2015-03-29 19:50

reporter   ~0082434

No tabs on the line.

od -c reveals that the file in question has \r\n as the end of line, which may be relevant?

Martin Friebe

2015-03-29 19:53

manager   ~0082436

Can you please compile the IDE with
   VerboseUpdateIfDefNodeStates
defined?

and run with a logfile --debug-log=file or with console?

And I need at least some context of the source,

Martin Friebe

2015-03-29 20:35

manager   ~0082438

Also, do you have or had at any time during this Lazarus session more than one SourceEditor window open?

Did you make (either right before, or at an earlier time during this Lazarus session) any changes to the highlighter?


"during this Lazarus session" = since you started the current instance of Lazarus.

C Western

2015-03-29 22:56

reporter   ~0082451

I have one source editor window with, multiple mtabs
I have not changed any highlighter changes

Compiling the ide with VerboseUpdateIfDefNodeStates defined does not seem to produce any additional console output.

It may be relevant that the project has two forms, one of which is a data module. The number and ordering of windows seems to be important in triggering the bug - it definitely comes and goes

Martin Friebe

2015-03-29 23:03

manager   ~0082452

Last edited: 2015-03-29 23:05

View 2 revisions

Reproduced / no further input needed


You probably have 2 units, both have some ifdef on line 6.

And at lest one of them has no ifdefs below line 6 / the other none above.

C Western

2015-03-29 23:47

reporter   ~0082454

Sounds promising - the .lpr file (which I had open) only has an ifdef on line 6. The file with {$ifdef mswindows} windows, {$endif} in has a $I sbove, but no ifdefs.

Martin Friebe

2015-03-29 23:48

manager   ~0082455

Please test with r48532

C Western

2015-03-30 23:20

reporter   ~0082479

Looks good thanks, though with the caveat that I couldn't always trigger it

Issue History

Date Modified Username Field Change
2015-03-29 13:22 C Western New Issue
2015-03-29 18:02 Martin Friebe Assigned To => Martin Friebe
2015-03-29 18:02 Martin Friebe Status new => assigned
2015-03-29 18:06 Martin Friebe LazTarget => -
2015-03-29 18:06 Martin Friebe Note Added: 0082429
2015-03-29 18:06 Martin Friebe Status assigned => feedback
2015-03-29 18:30 Martin Friebe Note Added: 0082430
2015-03-29 18:41 C Western Note Added: 0082431
2015-03-29 18:41 C Western Status feedback => assigned
2015-03-29 19:30 Martin Friebe Note Added: 0082433
2015-03-29 19:50 C Western Note Added: 0082434
2015-03-29 19:53 Martin Friebe Note Added: 0082436
2015-03-29 20:35 Martin Friebe Note Added: 0082438
2015-03-29 22:56 C Western Note Added: 0082451
2015-03-29 23:03 Martin Friebe Note Added: 0082452
2015-03-29 23:05 Martin Friebe Note Edited: 0082452 View Revisions
2015-03-29 23:47 C Western Note Added: 0082454
2015-03-29 23:48 Martin Friebe Fixed in Revision => 48532
2015-03-29 23:48 Martin Friebe LazTarget - => 1.4
2015-03-29 23:48 Martin Friebe Note Added: 0082455
2015-03-29 23:48 Martin Friebe Status assigned => resolved
2015-03-29 23:48 Martin Friebe Fixed in Version => 1.5 (SVN)
2015-03-29 23:48 Martin Friebe Resolution open => fixed
2015-03-29 23:48 Martin Friebe Target Version => 1.4
2015-03-30 23:20 C Western Note Added: 0082479