View Issue Details

IDProjectCategoryView StatusLast Update
0027803LazarusOtherpublic2015-04-28 13:34
ReporterJosé MartínezAssigned ToMaxim Ganetsky 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Platformi386OSWindowsOS VersionXP
Product Version1.4RC2Product Build48058 
Target VersionFixed in Version1.4.2 
Summary0027803: es.po files with updated translation/corrections to Spanish
DescriptionUpdated Spanish translation files es.po files.
Attach a zip file containing 22 files.

I hope it works, if errors please report to correct it.

Thanks.
TagsNo tags attached.
Fixed in Revision48851
LazTarget-
Widgetset
Attached Files

Activities

José Martínez

2015-04-07 16:27

reporter  

Ficheros_ es_poTraducidos.zip (230,103 bytes)

Jesus Reyes

2015-04-09 07:39

developer  

Ficheros_po_es_traducidos_revision.zip (239,891 bytes)

Maxim Ganetsky

2015-04-09 15:08

developer   ~0082749

Please review attached translations which were modified by Jesus Reyes.

José Martínez

2015-04-23 10:59

reporter   ~0083129

Last edited: 2015-04-23 11:53

View 8 revisions

Sorry, but i have been busy.
Thanks Jesús Reyes. When i translated/reviewed i saved it in plain text but not in UTF-8 (Thanks for the correction). I´m looking for menu entries and i have been found this:

Supongo que con el Writer de Libre Office tengo que selección Texto Plano y luego Unicode (UTF-8).
La otra cuestión es el salto de párrafo ¿CR-LF? ¿CR? ¿LF?

Lo que sucede es que a la hora de cargarlo en edición luego (aunque el IDE lo presenta correctamente) me aparece como interrupción para los acentos y por ejemplo para la ñ Añadir

En Archivo -> Print ... i need and english string to traslate as Imprimir ...
En Ver -> Leaks and Traces (same as before).
En Herramientas -> Project Templates Options ... (same as before)

En Herramientas -> Conversión Delphi > Convertir Codificación de página de Proyectos/Paquetes (Aquí le falta el icono al igual que lo tienen las otras entradas)

Ando dándole vueltas a si es conveniente poner en mayusculas únicamente la primera letra de cada entrada o poner todas las que inician cada palabra.

¿que opinas?

También he visto algún pequeño error tipográfico así que lo subo corregido en breve.

Como he visto que hay correcciones a cosas interesantes como el overlap del treeview y algún otro supongo que se acabará sacando la 1.4.x así que a ver si para entonces se puede incluir todo el menú traducido.

Disculpar que esto lo ponga en español pero es mi idioma nativo y en inglés me cuesta expresarme aunque no me importa dedicar tiempo a las traducciones.

José Martínez

2015-04-23 17:17

reporter  

Ficheros_po_es_traducidos_revision_plus.zip (228,649 bytes)

José Martínez

2015-04-23 17:23

reporter   ~0083142

Hello, in File Ficheros_es_po_traducidos_revision.zip i have been updated lazaruside.es.po because it have somethings to fix. Now i think its OK :)

Hola Jesús, salvo por las notas previas en el menú del IDE se muestra bien, he modificado alguna cadena pero son pequeñas cosas. He utilizado un editor exadecimal, prácticamente ha consistido en cambiar alguna mayúscula y algo con acentos, el formato en si no ha cambiado tal como lo modificaste. Esperemos que sirva para que la gente se encuentre agusto con el entorno.

Saludos.

Maxim Ganetsky

2015-04-23 17:52

developer   ~0083144

Did you check your translation with PoChecker?

José Martínez

2015-04-23 18:24

reporter   ~0083145

After Jesus modifications? NO.
I will try.

Maxim Ganetsky

2015-04-25 20:06

developer   ~0083221

Applied with exception of h2passtrconsts.es.po (it is invalid and could not be opened by PoEdit).

Please in future edit .po files with programs like poEdit (www.poedit.net) or Lokalize. Do not edit them manually or in LibreOffice. This will help to avoid such files corruption.

Also please read <lazarus dir>/languages/README.txt.

Thanks for contribution.

Jesus Reyes

2015-04-25 20:56

developer   ~0083223

Last edited: 2015-04-25 20:57

View 2 revisions

ups
I have days working on this...
Just finished and was to about to give some feed back here.. I will check the differences against my version.....

Maxim Ganetsky

2015-04-25 21:43

developer   ~0083224

Last edited: 2015-04-25 21:44

View 2 revisions

@Jesus: sorry for the inconvenience. Feel free to commit your corrections as you see fit. I can revert this commit if you want.

Jesus Reyes

2015-04-26 01:39

developer   ~0083228

@Maxim: np. After all it helped me to know PoChecker didn't check for extras quotes " :)

@Jose: Si, estoy de acuerdo con Maxim al respecto de que lo mejor es usar un programa dedicado. En particular creo que poEdit hace un buen trabajo, a parte de que tiene una opción que verifica que algunas cosas estén bien en el archivo. Por eso se recomienda procesar los archivos con PoChecker que verifica otras que poEdit no puede. Es decir la combinación PoChecker+poEdit ayuda bastante en esta tarea.

En ausencia de poEdit sugeriría el uso de NotePad++ o el editor de textos de DoubleCommander, en particular este último (y su visor de archivos) te muestran la codificación de los archivos si éstos son UTF-8 u otra codificación (y puedes cambiarla si es necesario). Con esto evitarás problemas como lo del ñ Añadir, etc.

Con respecto a CR/LF, esto en realidad no importa mucho, pero por consistencia, usar CRLF en windows y LF en Linux o Mac.

Voy a revisar las partes que mencionas y que aún no cuentan con texto de traducción. Confirmo lo de "Print...", así como lo del icono.

Con respecto a si usar mayúsculas en los elementos de menú, en particular me gustaría que solo la primer letra fuera mayúscula y lo demás minúsculas, pero efectivamente el texto en inglés viene en ocasiones mezclado y pues tampoco veo mayor problema en seguir esa tendencia. Pero solo es mi opinión. Sería bueno tener una discusión de eso en algún foro/lista y saber que piensa la comunidad.

De antemano agradezco la molestia que te tomas en traducir Lazarus, así como te animo a continuar con esta tarea, creo que con las sugerencias presentadas esta tarea será cada vez mas sencilla.

Quizas una sugerencia extra es siempre usar UTF-8 en archivos. Aunque los archivos po tienen un encabezado con meta información a cerca de la codificación del archivo, me parece (no recuerdo bien) que Lazarus solo puede procesar correctamente archivos codificados en UTF-8.

Another hint, would be to use the original directory layout for packaging the po files, in this way and assuming the lazarus directory is the root, the file lazaruside.es would be languages/lazaruside.es, this should help to quickly integrate the patch into the working lazarus directoy for testing and commit. But basically this should be decided by Maxim, he has the last word on this. This is why I use english for this hint.

Aquí me detengo, gracias de nuevo.

Maxim Ganetsky

2015-04-26 20:52

developer   ~0083244

Last edited: 2015-04-27 01:23

View 2 revisions

> Another hint, would be to use the original directory layout for packaging the po files, in this way and assuming the lazarus directory is the root.

This is not very important for me.

BTW, should your commit be merged to fixes and should I resolve this bug report?

José Martínez

2015-04-27 15:44

reporter   ~0083270

===============================================================================
(0083221)
Maxim Ganetsky (desarrollador)
2015-04-25 20:06

    Applied with exception of h2passtrconsts.es.po (it is invalid and could not be opened by PoEdit).

Please in future edit .po files with programs like poEdit (www.poedit.net) or Lokalize. Do not edit them manually or in LibreOffice. This will help to avoid such files corruption.

Also please read <lazarus dir>/languages/README.txt.

Thanks for contribution.
============================================================================

OK, h2passtrconsts.es.po was LF so Poedit was unable to load the file because expected CR-LF.
Also as Jesus commented pochecker was unable to detect extra "
Finaly both pochecker and poedit load and checked all ok.

Now i´m going to test the rest of files.

Thanks for the utilities. Now i have pochecker, notepad++ and poedit :)

José Martínez

2015-04-27 17:37

reporter   ~0083274

Hello, Jesus Reyes, i have only one error but i dont know how to fix it. Have it been deleted from master? or is an added error in the po traslated?
==============================================================================
-------------------------------------------------------
Errores / advertencias reportadas por CheckNrOfItems para:
lazaruside.es.po
-------------------------------------------------------

Discrepancia en el número de elementos para el maestro y el hijo
lazaruside.po: 4717 elementos
lazaruside.es.po: 4718 elementos
-------------------------------------------------------


-------------------------------------------------------
Errores / advertencias reportadas por CheckMissingIdentifiers para:
lazaruside.es.po
-------------------------------------------------------

[Línea: 5230]
Identificador [lazarusidestrconsts.lisclassesppunotfoundcheckyourfpccfg] se encuentra en lazaruside.es.po, pero no existe en lazaruside.po

Encontrados 1 errores.
-------------------------------------------------------


-------------------------------------------------------
Translation statistics per language:

D:\traducirlazarus\Ficheros_po_es_traducidos_revision_plus\revisar\lazaruside.es.po
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx : 99,9% translated strings.
                                                  : 0,0% untranslated strings.
x : 0,1% fuzzy strings.


-------------------------------------------------------
Total errors found: 2
Total de avisos encontrados: 0
================================================================================

Jesus Reyes

2015-04-27 20:22

developer   ~0083277

Yes, it means the entry lazarusidestrconsts.lisclassesppunotfoundcheckyourfpccfg which exists in lazaruside.es.po do not have a matching entry in the lazaruside.po file. This entry should be removed from lazaruside.es.po.

By the way, I have committed some missing .es.po files for printing code and leakviewer.

Please for reporting additional items open new bug report tickets. For questions please use the lazarus mailing list (or the spanish one if you like) or you can also contact me at jesusrmx.at.yahoo.com.mx.

If the main topic of this report has been solved, please close the report.

José Martínez

2015-04-28 13:34

reporter   ~0083295

Resuelta. :)

Issue History

Date Modified Username Field Change
2015-04-07 16:27 José Martínez New Issue
2015-04-07 16:27 José Martínez File Added: Ficheros_ es_poTraducidos.zip
2015-04-07 22:46 Maxim Ganetsky Assigned To => Maxim Ganetsky
2015-04-07 22:46 Maxim Ganetsky Status new => assigned
2015-04-09 07:39 Jesus Reyes File Added: Ficheros_po_es_traducidos_revision.zip
2015-04-09 15:08 Maxim Ganetsky LazTarget => -
2015-04-09 15:08 Maxim Ganetsky Note Added: 0082749
2015-04-09 15:08 Maxim Ganetsky Status assigned => feedback
2015-04-23 10:59 José Martínez Note Added: 0083129
2015-04-23 10:59 José Martínez Status feedback => assigned
2015-04-23 11:04 José Martínez Note Edited: 0083129 View Revisions
2015-04-23 11:05 José Martínez Note Edited: 0083129 View Revisions
2015-04-23 11:11 José Martínez Note Edited: 0083129 View Revisions
2015-04-23 11:15 José Martínez Note Edited: 0083129 View Revisions
2015-04-23 11:15 José Martínez Note Edited: 0083129 View Revisions
2015-04-23 11:24 José Martínez Note Edited: 0083129 View Revisions
2015-04-23 11:53 José Martínez Note Edited: 0083129 View Revisions
2015-04-23 17:17 José Martínez File Added: Ficheros_po_es_traducidos_revision_plus.zip
2015-04-23 17:23 José Martínez Note Added: 0083142
2015-04-23 17:52 Maxim Ganetsky Note Added: 0083144
2015-04-23 17:52 Maxim Ganetsky Status assigned => feedback
2015-04-23 18:24 José Martínez Note Added: 0083145
2015-04-23 18:24 José Martínez Status feedback => assigned
2015-04-25 20:06 Maxim Ganetsky Fixed in Revision => 48851
2015-04-25 20:06 Maxim Ganetsky Note Added: 0083221
2015-04-25 20:06 Maxim Ganetsky Status assigned => resolved
2015-04-25 20:06 Maxim Ganetsky Fixed in Version => 1.4.2
2015-04-25 20:06 Maxim Ganetsky Resolution open => fixed
2015-04-25 20:56 Jesus Reyes Note Added: 0083223
2015-04-25 20:57 Jesus Reyes Note Edited: 0083223 View Revisions
2015-04-25 21:43 Maxim Ganetsky Note Added: 0083224
2015-04-25 21:44 Maxim Ganetsky Note Edited: 0083224 View Revisions
2015-04-25 23:34 Maxim Ganetsky Status resolved => assigned
2015-04-25 23:34 Maxim Ganetsky Resolution fixed => reopened
2015-04-26 01:39 Jesus Reyes Note Added: 0083228
2015-04-26 20:52 Maxim Ganetsky Note Added: 0083244
2015-04-27 01:23 Maxim Ganetsky Note Edited: 0083244 View Revisions
2015-04-27 15:44 José Martínez Note Added: 0083270
2015-04-27 17:37 José Martínez Note Added: 0083274
2015-04-27 20:22 Jesus Reyes Note Added: 0083277
2015-04-27 23:27 Maxim Ganetsky Status assigned => resolved
2015-04-27 23:27 Maxim Ganetsky Resolution reopened => fixed
2015-04-28 13:34 José Martínez Note Added: 0083295
2015-04-28 13:34 José Martínez Status resolved => closed