View Issue Details

IDProjectCategoryView StatusLast Update
0027959PackagesDatabasepublic2015-12-15 20:02
ReporterBill Assigned ToLuiz Americo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOS64-bit 
Summary0027959: tDBF Filter statements no longer work in 1.4
DescriptionI have apps that were working fine in 1.2.6 and after installing 1.4, some functionality no longer works. In one example, tdBF filter statements that used to work now do not. For example:

procedure TForm1.Button1Click(Sender: TObject);
begin
  with dbf1 do begin
      // Filter := ComboBox1.Text + '=' + QuotedSTR(DBLookupComboBox1.Text);
      Filter := ComboBox1.Text + '=' + AnsiQuotedSTR(DBLookupComboBox1.Text,'"');
      Filtered := True;
      end
end;
Steps To ReproduceSee attached project.

1. Compile and run the program
2. Select a field from the drop down list.
3. Select a field value from the drop down list
4. Press filter button.

Expected Behavior: The table will filter to one row (works under 1.2.6)
Current Behavior: The table will not filter.
Additional Informationhttp://forum.lazarus.freepascal.org/index.php/topic,28144.0.html
TagsNo tags attached.
Fixed in Revision50763
LazTarget-
Widgetset
Attached Files

Relationships

related to 0026356 closedLuiz Americo Lazarus the TDBLookupComboBox Don't work 

Activities

Bill

2015-04-24 20:18

reporter  

dblookupcombosort.zip (6,133 bytes)

Jonas Maebe

2015-04-24 20:31

viewer   ~0083169

Since both Lazarus 1.2.6 and 1.4.0 are based on FPC 2.6.4, this is probably a Lazarus issue.

Michael Van Canneyt

2015-04-24 21:07

administrator   ~0083171

Indeed. Moving to lazarus.

LacaK

2015-04-25 10:07

developer   ~0083197

Probably recent changes in LCL/include/dblookup.inc (rev.44875 ?) causes it.

LacaK

2015-04-27 11:54

developer   ~0083267

Last edited: 2015-04-27 14:17

View 4 revisions

culprit is rev.45578 (related to 0026356)

 Seting Filtered:=True generates deDatasetChange which is catch by TDBLookupDatalink.DataEvent and later in TDBLookup.FetchLookupData
 ListLinkDataSet.EnableControls generates again deDatasetChange which causes cycling!

Bill

2015-07-01 18:24

reporter   ~0084819

Is this going to get fixed in 1.4.1 or ?

LacaK

2015-07-02 07:27

developer   ~0084828

Last edited: 2015-07-02 07:30

View 3 revisions

As all datasets now (in trunk and also in 3.0.x) supports dsBlockRead state simplest fix will be revert rev.44875 as reason for this patch (missing support for dsBlockRead in TMemDataset) no more exists.
(and do not backport to 1.4, leave only in Lazarus trunk; or wait for FPC 3.0 and then fix)

Bill

2015-07-14 23:02

reporter   ~0084944

I installed 1.4.2, replaced dblookup.inc with rev.44875, and everything seems to work.

But still, this needs to get fixed, and is hardly a minor issue as stated above. Database filtering is important functionality. I hope this issue can get the attention it deserves before another release goes out broken.

Luiz Americo

2015-12-15 02:38

developer   ~0087962

Fixed in trunk

Issue History

Date Modified Username Field Change
2015-04-24 20:18 Bill New Issue
2015-04-24 20:18 Bill File Added: dblookupcombosort.zip
2015-04-24 20:31 Jonas Maebe Note Added: 0083169
2015-04-24 20:31 Jonas Maebe Project FPC => Lazarus
2015-04-24 21:06 Michael Van Canneyt Project Lazarus => Packages
2015-04-24 21:07 Michael Van Canneyt Note Added: 0083171
2015-04-25 10:07 LacaK Note Added: 0083197
2015-04-27 11:54 LacaK Note Added: 0083267
2015-04-27 12:04 LacaK Note Edited: 0083267 View Revisions
2015-04-27 14:15 LacaK Note Edited: 0083267 View Revisions
2015-04-27 14:17 LacaK Note Edited: 0083267 View Revisions
2015-07-01 18:24 Bill Note Added: 0084819
2015-07-02 07:27 LacaK Note Added: 0084828
2015-07-02 07:28 LacaK Note Edited: 0084828 View Revisions
2015-07-02 07:30 LacaK Note Edited: 0084828 View Revisions
2015-07-14 23:02 Bill Note Added: 0084944
2015-07-15 17:51 Maxim Ganetsky Assigned To => Luiz Americo
2015-07-15 17:51 Maxim Ganetsky Status new => assigned
2015-12-12 01:34 Juha Manninen Relationship added related to 0026356
2015-12-15 02:38 Luiz Americo Fixed in Revision => 50763
2015-12-15 02:38 Luiz Americo LazTarget => -
2015-12-15 02:38 Luiz Americo Note Added: 0087962
2015-12-15 02:38 Luiz Americo Status assigned => resolved
2015-12-15 02:38 Luiz Americo Resolution open => fixed