View Issue Details

IDProjectCategoryView StatusLast Update
0027962LazarusLCLpublic2015-04-29 08:23
ReporterIan UptonAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformToshiba U840WOSLinux MintOS Version17 64 bit
Product Version1.4Product BuildLAZ 1.4, FPC 2 
Target Version1.6Fixed in Version1.5 (SVN) 
Summary0027962: Desktop locks on DBGrid add/modify column.
DescriptionThe project was built using LAZ 1.2.4.
Currently being developed under 1.4. No sign of this problem under 1.2.4.

The problem is with attempting to add or modify a column in DBGrid. As follows:

Form with DBGrid displayed, DBGrid in object editor.

Click on columns in the object editor, 6, columns displayed in window 'Editing DBGrid.Columns'.

Select a column.

Displayed in the object editor

Click on 'fieldname'.

A window is displayed 'Abstract method called' OK to ignore, cancel to kill.

If I click on OK the ENTIRE system locks up, mouse and keys have no effect on anything on the desktop.
The only thing is to power off the computer.
Steps To ReproduceUnder LAZ 1.4 If I create a new project, add DBGrid, DataSource and BufDataset.

Create a column, attempt to add a fieldname to the DBGrid.

Same problem 'Abstract method called".
TagsNo tags attached.
Fixed in Revision48889
LazTarget1.6
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0025829 resolvedReinier Olislagers FPC Error Access violation SQLdb 

Activities

Jesus Reyes

2015-04-25 04:32

developer   ~0083188

I tried to reproduce the problem as described, I was not successful. Maybe there is something that is missing. Please attach a sample project and data.

Ian Upton

2015-04-25 08:47

reporter  

DBGridCrash.tar.gz (129,851 bytes)

Ian Upton

2015-04-25 08:49

reporter   ~0083190

Zip of test project.

In IDE click on dbgrid>column.
In Column editor window select the column.

In the object editor select field name, 'abstract....'.

Thanks,Ian.

Jesus Reyes

2015-04-25 10:03

developer   ~0083196

Last edited: 2015-04-25 10:07

View 2 revisions

Ok, this happened to be a known problem of FPC 2.6.4 (and probably 2.6.2) which however do not happen with FPC trunk (actually any FPC revision before 27021 would fail), see related bug report.

Actually I think we should do something about it in Lazarus, please do the following: open the file lazarus/components/ideintf/dbpropedits.pp around line 81, you should find this line:

         DataSet.FieldDefs.Update;

please modify the source code so it reads this way:

        try
          DataSet.FieldDefs.Update;
        except
          // some FPC versions will fail here, but having persistent fields should
          // actually work or else present an empty list of fields... but not crash/freeze
          if Dataset.FieldDefs.Count=0 then begin
            List.Clear;
            raise Exception.Create('Unable to retrieve fields information from dataset');
          end;
        end;

Save the changes and recompile lazarus (tools->Build lazarus.....) once Lazarus is recompiled, try again and report your findings.

Ian Upton

2015-04-25 11:59

reporter   ~0083205

Jesus,

Thank you for the rapid response.

I applied the changes specified.

Works OK,I can select a field name without any problems.

Thanks once again. Ian.

Please close this bug.

Jesus Reyes

2015-04-29 08:23

developer   ~0083317

Changed of the raising of exception to simply displaying a message box.

Issue History

Date Modified Username Field Change
2015-04-25 01:10 Ian Upton New Issue
2015-04-25 04:30 Jesus Reyes Assigned To => Jesus Reyes
2015-04-25 04:30 Jesus Reyes Status new => assigned
2015-04-25 04:32 Jesus Reyes LazTarget => -
2015-04-25 04:32 Jesus Reyes Note Added: 0083188
2015-04-25 04:32 Jesus Reyes Status assigned => feedback
2015-04-25 08:47 Ian Upton File Added: DBGridCrash.tar.gz
2015-04-25 08:49 Ian Upton Note Added: 0083190
2015-04-25 08:49 Ian Upton Status feedback => assigned
2015-04-25 10:03 Jesus Reyes Note Added: 0083196
2015-04-25 10:04 Jesus Reyes Relationship added duplicate of 0025829
2015-04-25 10:07 Jesus Reyes Note Edited: 0083196 View Revisions
2015-04-25 11:59 Ian Upton Note Added: 0083205
2015-04-29 08:23 Jesus Reyes Fixed in Revision => 48889
2015-04-29 08:23 Jesus Reyes LazTarget - => 1.6
2015-04-29 08:23 Jesus Reyes Note Added: 0083317
2015-04-29 08:23 Jesus Reyes Status assigned => resolved
2015-04-29 08:23 Jesus Reyes Fixed in Version => 1.5 (SVN)
2015-04-29 08:23 Jesus Reyes Resolution open => fixed
2015-04-29 08:23 Jesus Reyes Target Version => 1.6