View Issue Details

IDProjectCategoryView StatusLast Update
0000028Lazaruspublic2002-05-02 04:29
ReporterBug ImportAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0000028: Lazarus still not running
DescriptionI've reinstalled all fpc 1.0.5 and lazarus (got by
cvs today, the 13 february 2001), and i can
compile lazarus without problem, but when i run
it, i still got a crash...

Marc Weustink said i need the librairies for
fpc 1.0.5, i'm not sure i understand very well
what he means. Are these librairies all the *.ppu
found in /usr/lib/fpc/1.0.5 ? Or others ?

I'm under Mandrake 7.1, is it the cause of the
problem ?

here is the message i got when running :
LM_SCREENINIT called --> should go to GTKObject.Init
TODO: check this
TODO: WINAPI call CHARLOWERBUFF
[TCustomForm.Create] Resource 'TSPLASHFORM' not found
This is for information purposes only. This is not critical at this time.
[TCustomForm.Create] Resource 'TMAINIDE' not found
This is for information purposes only. This is not critical at this time.
[INAVLIDATECONTROL]
[INAVLIDATECONTROL] Done
[INAVLIDATECONTROL]
[INAVLIDATECONTROL] Done

... a lot of such things ...

[INAVLIDATECONTROL] Done
[TCustomForm.Create] Resource 'TFINDDIALOG' not found
This is for information purposes only. This is not critical at this time.
[TCustomForm.Create] Resource 'TOBJECTINSPECTOR' not found
This is for information purposes only. This is not critical at this time.
[TCustomComboBox] AttachSignals
[TCustomComboBox] Exiting AttachSignals
[TCustomComboBox] DoChange
An unhandled exception occurred at 0x401E27D6 :
Access violation
  0x401E27D6
  0x401EAC73
  0x401CBBFB
  0x401EE0EF
  0x401ECC5A
  0x401955FD
  0x080B0AD5
  0x4020C73F
  0x4021415A
  0xBFFFE650
  0xBFFFE664
  0x00000001
  0x08185B70

An unhandled exception occurred at 0x00000021 :
Access violation
  0x00000021
  0x080CE72C
  0x080FEB4F
  0x080CE9DF
  0x080F0C0B
  0x080F0BB7
  0x080D5C85
  0xBFFFF58C
An unhandled exception occurred at 0x080F9D3A :
Access violation
  0x080F9D3A
  0x3020200C
  0x00000000

[TgtkObject.Destroy] WARNING: There are 2 unreleased DCs and 54 unreleased GDIObjects
[TgtkObject.Destroy] WARNING: There are 4 messages left in the queue! I'll free them

Additional InformationImported information
--------------------
Name: Denis L├ęger
Mail: denis.leger (at) laposte.net
TagsNo tags attached.
Fixed in Revision
LazTarget
WidgetsetGTK, Win32/Win64
Attached Files

Activities

Bug Import

2002-05-02 04:29

reporter   ~0000027

In order to get the new libraries you need to do a

cvs co -r FIXES_1_0_0 packages compiler rtl

That pulls the 1.0.5 version of the compiler.
If you've done that then pull Lazarus from CVS again and retry. let us know if it's working.

MG: seems to be fixed

Issue History

Date Modified Username Field Change
2001-02-13 00:00 Bug Import New Issue
2001-02-13 00:00 Bug Import Widgetset => GTK, Win32
2002-05-02 04:29 Bug Import Status new => assigned
2002-05-02 04:29 Bug Import Assigned To => Mattias Gaertner
2002-05-02 04:29 Bug Import Note Added: 0000027
2002-05-02 04:29 Bug Import Status new => closed
2002-05-02 04:29 Bug Import Resolution open => no change required