View Issue Details

IDProjectCategoryView StatusLast Update
0028022FPCCompilerpublic2020-03-01 04:11
ReporterCyrax Assigned ToFlorian  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformWindows OSServer 2008 R2 
Product Version3.1.1 
Fixed in Version3.3.1 
Summary0028022: Internal error 2014010312 when compiling unit which accidentally contains class method definitions of another class.
DescriptionCompiler gives internal error 2014010312 when compiling unit which accidentally contains class method definitions in its implementation section. This class is already defined (and its methods) in separate unit which is used in the first unit.

The second unit is in uses clause of the first units interface section.

This bug occurs only when doing subsequent compiles. Full build resets this.

See attached project, Steps to reproduce and Additional Information for more info.
Steps To Reproduce1. Compile attached project. Ignore errors.
2. Do second compile.
Additional InformationLazarus revision 48926
FPC revision 30794
 
FPC make commands:
clean
all
install
OPT=-gw2 -godwarfsets -gl -O- -OoNO -Xs- -Si- -vb -XX -CX -dTEST_WIN32_SEH
COMPILER_OPTIONS=-gw2 -godwarfsets -gl -O- -OoNO -Xs- -Si- -vb -XX -CX -dTEST_WIN32_SEH
INSTALL_PREFIX=F:\free_pascal_and_lazarus\fpc\i386\trunk\binary\fpc_trunk
UPXPROG=echo
IDE=1
REVSTR=30794
 
Lazarus make commands:
clean
all
OPT=-gw2 -godwarfsets -gl -gh -O- -OoNO -Xs- -Si- -vb -XX -CX -dTEST_WIN32_SEH -dHEAPTRC_WINDOW -dDBG_WITH_DEBUGGER_DEBUG
UPXPROG=echo
USESVN2REVISIONINC=0

---

FPC command line parameters for the attached project:

--
 -MObjFPC -Scghi -gw2 -godwarfsets -gl -l -vewnhibq -Filib\i386-win32-win32-30101 -Fusrc -Fu. -FUlib\i386-win32-win32-30101 -FEbin\i386-win32-win32-30101\
--
TagsNo tags attached.
Fixed in Revision44170
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0036652 closedSven Barth 2014010312 error 

Activities

Cyrax

2015-05-04 02:00

reporter  

project.zip (2,084 bytes)

Cyrax

2015-05-04 02:01

reporter  

fpc_output.txt (788 bytes)   
Hint: (11030) Start of reading config file F:\free_pascal_and_lazarus\fpc\i386\trunk\binary\fpc_trunk\bin\i386-win32\fpc.cfg
Hint: (11031) End of reading config file F:\free_pascal_and_lazarus\fpc\i386\trunk\binary\fpc_trunk\bin\i386-win32\fpc.cfg
Free Pascal Compiler version 3.1.1-r30794 [2015/05/04] for i386
Copyright (c) 1993-2015 by Florian Klaempfl and others
(1002) Target OS: Win32 for i386
(3104) Compiling project1.lpr
(3104) Compiling .\src\unit_test.pas
U:\32-bit\kielet\pascal\free_pascal\lazarus\projects\research\source 18\fpc internal error test 00\.\src\unit_test.pas(13,1) Fatal: Internal error 2014010312
Fatal: (1018) Compilation aborted
Error: F:\free_pascal_and_lazarus\fpc\i386\trunk\binary\fpc_trunk\bin\i386-win32\ppc386.exe returned an error exitcode
fpc_output.txt (788 bytes)   

Cyrax

2015-10-19 03:19

reporter  

project1.zip (2,095 bytes)

Cyrax

2015-10-19 03:21

reporter   ~0086700

Attached updated project file.

This issue still persists.

---

Lazarus revision 50117
FPC revision 32066
 
FPC make commands:
clean
all
install
OPT=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vbq -XX -CX -dTEST_WIN32_SEH
COMPILER_OPTIONS=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vbq -XX -CX -dTEST_WIN32_SEH
INSTALL_PREFIX=F:\free_pascal_and_lazarus\fpc\i386\trunk\binary\fpc_trunk
UPXPROG=echo
IDE=1
REVSTR=32066
ALLOW_WARNINGS=1
NOWPOCYCLE=1
 
Lazarus make commands:
clean
all
OPT=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -gh -O- -OoNO -Xs- -Si- -vb -XX -CX -dTEST_WIN32_SEH -dHEAPTRC_WINDOW -dDBG_WITH_DEBUGGER_DEBUG
UPXPROG=echo
USESVN2REVISIONINC=0

Thaddy de Koning

2020-02-17 11:11

reporter   ~0121143

Last edited: 2020-02-17 11:12

View 2 revisions

Jan Bruns refered to this today, but although status open, this is actually fixed. (r44200)
The compiler throws a proper error:
---
Compile Project, Mode: Default, Target: bin/arm-linux-gtk2-30301/project1: Exit code 1, Errors: 2
unit_test.pas(12,19) Error: Implementing a method for type "TTest" declared in another unit
unit_test.pas(17,18) Error: Implementing a method for type "TTest" declared in another unit
---

Issue History

Date Modified Username Field Change
2015-05-04 02:00 Cyrax New Issue
2015-05-04 02:00 Cyrax File Added: project.zip
2015-05-04 02:01 Cyrax File Added: fpc_output.txt
2015-10-19 03:19 Cyrax File Added: project1.zip
2015-10-19 03:21 Cyrax Note Added: 0086700
2020-02-17 11:11 Thaddy de Koning Note Added: 0121143
2020-02-17 11:12 Thaddy de Koning Note Edited: 0121143 View Revisions
2020-02-17 21:16 Florian Relationship added related to 0036652
2020-02-17 21:17 Florian Relationship replaced duplicate of 0036652
2020-02-17 21:17 Florian Assigned To => Florian
2020-02-17 21:17 Florian Status new => resolved
2020-02-17 21:17 Florian Resolution open => duplicate
2020-02-17 21:17 Florian Fixed in Version => 3.3.1
2020-02-17 21:17 Florian Fixed in Revision => 44170
2020-02-17 21:17 Florian FPCTarget => -
2020-03-01 04:11 Cyrax Status resolved => closed