View Issue Details

IDProjectCategoryView StatusLast Update
0028065LazarusIDEpublic2019-11-04 23:38
ReporterJZSAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSWin8OS Version
Product Version1.4Product Build 
Target VersionFixed in Version 
Summary0028065: "Remove from project..." does not remove all selected units
DescriptionWhen Multi Select is checked and more than one unit is selected, when the button Ok is clicked only the top selected unit is removed.
Steps To Reproducejust have multiple units project on and try to select couple of Units to remove from the menu-> Project -> Remove from Project...
Additional InformationI tried with 1.4 and 1.5 svn revision 48926.
It is the same in both of them.
TagsNo tags attached.
Fixed in Revisionr62194
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Juha Manninen

2015-05-11 21:39

developer   ~0083565

Cannot reproduce. Tested on Window and on Linux with both GTK2 and QT bindings.

JZS

2015-05-12 14:20

reporter  

Sample.zip (4,137 bytes)

JZS

2015-05-12 14:22

reporter   ~0083577

OK I just noticed that I am disabling the Forms AutoCreate:

//Application.CreateForm(TFormx, Formx);

Attached please find sample project.

Juha Manninen

2015-05-16 14:24

developer   ~0083647

Ok, I can reproduce with the sample project.
It seems to happen when the uses section has units which are not really used.

Juha Manninen

2019-11-04 23:38

developer   ~0119063

Fixed, please test.

Issue History

Date Modified Username Field Change
2015-05-10 11:17 JZS New Issue
2015-05-11 21:39 Juha Manninen Note Added: 0083565
2015-05-12 14:20 JZS File Added: Sample.zip
2015-05-12 14:22 JZS Note Added: 0083577
2015-05-16 14:24 Juha Manninen LazTarget => -
2015-05-16 14:24 Juha Manninen Note Added: 0083647
2015-05-16 14:24 Juha Manninen Assigned To => Juha Manninen
2015-05-16 14:24 Juha Manninen Status new => confirmed
2019-11-04 23:38 Juha Manninen Status confirmed => resolved
2019-11-04 23:38 Juha Manninen Resolution open => fixed
2019-11-04 23:38 Juha Manninen Fixed in Revision => r62194
2019-11-04 23:38 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2019-11-04 23:38 Juha Manninen Note Added: 0119063