View Issue Details

IDProjectCategoryView StatusLast Update
0028084LazarusDebuggerpublic2015-05-27 23:54
ReporterjacobbAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86 64OSWindowsOS Version7
Product Version1.4.1 (SVN)Product Build 
Target Version1.6Fixed in Version1.5 (SVN) 
Summary0028084: Call Stack window: Show ... at the start of filenames instead of at the end
DescriptionWhen showing filenames with a path in the Source column of the Call Stack window and the text doesn't fit then the last part is replaced with ...

It would generally be far more useful I think to have at least the last part visible that has the filename and to replace the first part where the path starts with ...

This way you won't have to move the mouse over the name or enlarge the column because usually the path for several files is the same and you are most interested in the actual filename.
TagsNo tags attached.
Fixed in Revision49093
LazTarget1.6
WidgetsetWin32/Win64
Attached Files

Activities

Martin Friebe

2015-05-18 23:35

manager   ~0083764

Please test and close if ok

jacobb

2015-05-27 23:54

reporter   ~0084049

Different than I imagined it but this works too, thanks.

Issue History

Date Modified Username Field Change
2015-05-13 14:04 jacobb New Issue
2015-05-13 14:04 jacobb Status new => assigned
2015-05-13 14:04 jacobb Assigned To => Martin Friebe
2015-05-18 23:35 Martin Friebe Fixed in Revision => 49093
2015-05-18 23:35 Martin Friebe LazTarget => 1.6
2015-05-18 23:35 Martin Friebe Note Added: 0083764
2015-05-18 23:35 Martin Friebe Status assigned => resolved
2015-05-18 23:35 Martin Friebe Fixed in Version => 1.5 (SVN)
2015-05-18 23:35 Martin Friebe Resolution open => fixed
2015-05-18 23:35 Martin Friebe Target Version => 1.6
2015-05-27 23:54 jacobb Note Added: 0084049
2015-05-27 23:54 jacobb Status resolved => closed