View Issue Details

IDProjectCategoryView StatusLast Update
0028096LazarusPackagespublic2016-01-20 17:55
ReporterTakeda MatsukiAssigned ToOndrej Pokorny 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSWindowsOS Version6.3
Product Version1.5 (SVN)Product Build49022 
Target Version1.6Fixed in Version1.7 (SVN) 
Summary0028096: AnchorDockingdsgn drive IDE into WM_Size Loop Detected
DescriptionOver a week I was tried to catch where is the spot which make Lazarus got WM_Size Loop detected on my Lazarus.. I check one by one.. And I found the "AnchorDockingdsgn" package was not compatible with some changes on IDE itself..

Stepping to produce :
1. Install the anchordocking package
2. Install the AnchordockingDsgn package
3. After Restart the IDE, Start to dock the Window..
4. Save the configuration. Close the IDE and Re Run the IDE..
5. Here we go.. The bug would come..
TagsNo tags attached.
Fixed in Revision51337,51338,51346
LazTarget1.6
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0018298 resolvedMattias Gaertner Please update the default layout provided with anchor docking package 
related to 0022747 resolvedOndrej Pokorny Error "TWinControl.WMSize loop detected" when starting Lazarus under Mac OS X 10.8.1 

Activities

Takeda Matsuki

2015-05-14 22:51

reporter  

Laz Error 20150511.png (17,641 bytes)
Laz Error 20150511.png (17,641 bytes)

Mattias Gaertner

2015-05-15 08:36

manager   ~0083613

Dock what window?
Please attach your anchordocklayout.xml.

Zeljan Rikalo

2015-05-15 08:47

developer   ~0083614

I don't understand this error message. Both bounds and new bounds are same , why error message ?

Takeda Matsuki

2015-05-16 22:03

reporter  

anchordocklayout.xml (2,506 bytes)

Takeda Matsuki

2015-05-16 22:03

reporter  

anchordockoptions.xml (117 bytes)

Takeda Matsuki

2015-05-16 22:06

reporter   ~0083671

Last edited: 2015-05-16 22:26

View 2 revisions

@Matias :

Done. I already attaching the files, Sir.

Please compile clean Lazarus then install anchordocking and anchordockingdsgn. Have you tried it?

Edit:
After install the packages above, Docking just like what I did, then save the layout, then close the Lazarus. Then Run the Lazarus, booommm... You got it..

Dirk Fellenberg

2016-01-16 16:39

reporter   ~0088964

The issue persists.
(Lazarus: trunk, SVN rev 51304; fpc 2.6.4 or fpc 3.0, OS: Windows 7, 32bit)
As described above, compile lazarus with anchordockingdsgn.lp, open lazarus, maximize application, close lazarus, open again: Error. Closing lazarus in an not maximized state will not produce the error.

Dirk Fellenberg

2016-01-16 16:40

reporter  

Juha Manninen

2016-01-16 17:28

developer   ~0088965

Last edited: 2016-01-16 18:30

View 3 revisions

No booommm here, maximized or not maximized.
Try with a clean configuration, for example by using the --pcp option.
The configuration format changed when the desktops feature was introduced. Your configuration may be corrupted by some intermediate broken revision.

If you still can reproduce with a clean config then explain the exact steps how to reproduce.
"After Restart the IDE, Start to dock the Window.." is not accurate enough.

[Edit] Actually I get some errors with the Windows version after playing with docking for a while. GTK2 and QT versions under Linux work well without errors always.

Ondrej Pokorny

2016-01-16 17:49

reporter   ~0088966

This one will probably be hard to solve. I once experienced the same issue with clean config. On the good side, I closed the WMSize loop errors (there were about 10) and then Lazarus started OK, although with a corrupted (default) layout. I then ordered the windows the way I wanted, saved the desktop and the errors haven't appeared ever since.

Ondrej Pokorny

2016-01-19 14:27

reporter   ~0089068

Last edited: 2016-01-19 14:31

View 2 revisions

Sorry Juha for taking over an issue assigned to you but I wanted to save you time since it seemed you tried to find the source of the problem at the wrong place (0029194).

FYI, the loop was caused by CoolBar and Palette initialization in TMainIDEBar.DoShow.

Please test.

Should it be merged to 1.6? - I don't know, maybe there will be some regressions I am not aware of. There's not much time to test for the 1.6. What do you think?

Balázs Székely

2016-01-19 21:07

developer   ~0089087

After r51338 lazarus won't start. Just to make sure I deleted everything, even the config folder. You can test it with a plain BIGIDE(r51337 it's ok, I'm on windows).

Ondrej Pokorny

2016-01-19 21:17

reporter   ~0089088

>> After r51338 lazarus won't start.

Ohhh yes :) Please test r51346

Balázs Székely

2016-01-19 21:31

developer   ~0089090

Now it's ok(the lazarus won't start part). To see if the bug it's gone, I need more time, since it's very sporadic, quite annoying and long lasting bug. :)

PS: I will also post it on the forum, so other people can test it.

Juha Manninen

2016-01-20 00:57

developer   ~0089102

Wow, thanks! I was indeed looking for the problem in a wrong place.

> Should it be merged to 1.6?

I think it should. It does not look an awfully dangerous change to me.
If it caused a regression I think it would show up quickly.
In my tests both the undocked and docked IDEs work well. I cannot say about the bug because I could not reproduce it recently.

Ondrej Pokorny

2016-01-20 10:02

reporter   ~0089108

Ok, I added it to the merge list.

Lübbe

2016-01-20 12:16

reporter   ~0089122

Wow, I was having the same issue and I just browsed through the issue tracker.
I thought it was related to different dual monitor layouts. When my primary monitor was on the right, it happened regularly, when it was on the left, it didn't happen.

While looking through issues with "WMSize" in the subject, I came accross issue 0022747, which looks like a duplicate to me. You might want to close it too.

Ondrej Pokorny

2016-01-20 12:42

reporter   ~0089124

>> In my tests both the undocked and docked IDEs work well. I cannot say about the bug because I could not reproduce it recently.

It was a Windows-only issue, if I am not mistaken.

Juha Manninen

2016-01-20 14:08

developer   ~0089125

> It was a Windows-only issue, if I am not mistaken.

Yes and I got the error messages under Wine at some point but not any more later.
Other users had similar experiences, the error did not happen always and not to everybody.

Ondrej Pokorny

2016-01-20 14:15

reporter   ~0089126

>> Other users had similar experiences, the error did not happen always and not to everybody.

The WM_SIZE loop can have different sources. This was only one of them. I think a corrupted layout (e.g. like in 0022747) can cause a WM_SIZE loop as well. Also some IDE extensions can cause it as well (packagetabs had this problem too).

Therefore I think this issue is resolved. Other WM_SIZE loops should be reported separately.

Balázs Székely

2016-01-20 17:55

developer   ~0089133

I wasn't able to reproduce it anymore. Let's hope it's gone for good!

Issue History

Date Modified Username Field Change
2015-05-14 22:51 Takeda Matsuki New Issue
2015-05-14 22:51 Takeda Matsuki File Added: Laz Error 20150511.png
2015-05-15 08:36 Mattias Gaertner LazTarget => -
2015-05-15 08:36 Mattias Gaertner Note Added: 0083613
2015-05-15 08:36 Mattias Gaertner Assigned To => Mattias Gaertner
2015-05-15 08:36 Mattias Gaertner Status new => feedback
2015-05-15 08:47 Zeljan Rikalo Note Added: 0083614
2015-05-16 22:03 Takeda Matsuki File Added: anchordocklayout.xml
2015-05-16 22:03 Takeda Matsuki File Added: anchordockoptions.xml
2015-05-16 22:06 Takeda Matsuki Note Added: 0083671
2015-05-16 22:06 Takeda Matsuki Status feedback => assigned
2015-05-16 22:26 Takeda Matsuki Note Edited: 0083671 View Revisions
2016-01-16 16:39 Dirk Fellenberg Note Added: 0088964
2016-01-16 16:40 Dirk Fellenberg File Added: Lazarus error ID28096 2016-01-16.png
2016-01-16 17:28 Juha Manninen Note Added: 0088965
2016-01-16 17:30 Juha Manninen Note Edited: 0088965 View Revisions
2016-01-16 17:49 Ondrej Pokorny Note Added: 0088966
2016-01-16 18:30 Juha Manninen Note Edited: 0088965 View Revisions
2016-01-19 00:55 Juha Manninen Assigned To Mattias Gaertner => Juha Manninen
2016-01-19 11:33 Juha Manninen Relationship added related to 0029194
2016-01-19 14:04 Ondrej Pokorny Relationship deleted related to 0029194
2016-01-19 14:04 Ondrej Pokorny Assigned To Juha Manninen => Ondrej Pokorny
2016-01-19 14:27 Ondrej Pokorny Fixed in Revision => 51337,51338
2016-01-19 14:27 Ondrej Pokorny Note Added: 0089068
2016-01-19 14:27 Ondrej Pokorny Status assigned => resolved
2016-01-19 14:27 Ondrej Pokorny Resolution open => fixed
2016-01-19 14:31 Ondrej Pokorny Note Edited: 0089068 View Revisions
2016-01-19 21:07 Balázs Székely Note Added: 0089087
2016-01-19 21:16 Ondrej Pokorny Fixed in Revision 51337,51338 => 51337,51338,51346
2016-01-19 21:17 Ondrej Pokorny Note Added: 0089088
2016-01-19 21:31 Balázs Székely Note Added: 0089090
2016-01-20 00:57 Juha Manninen Note Added: 0089102
2016-01-20 10:02 Ondrej Pokorny LazTarget - => 1.6
2016-01-20 10:02 Ondrej Pokorny Note Added: 0089108
2016-01-20 10:02 Ondrej Pokorny Fixed in Version => 1.7 (SVN)
2016-01-20 10:02 Ondrej Pokorny Target Version => 1.6
2016-01-20 12:16 Lübbe Note Added: 0089122
2016-01-20 12:28 Mattias Gaertner Relationship added related to 0018298
2016-01-20 12:40 Juha Manninen Relationship added related to 0022747
2016-01-20 12:42 Ondrej Pokorny Note Added: 0089124
2016-01-20 14:08 Juha Manninen Note Added: 0089125
2016-01-20 14:15 Ondrej Pokorny Note Added: 0089126
2016-01-20 17:55 Balázs Székely Note Added: 0089133