View Issue Details

IDProjectCategoryView StatusLast Update
0028130Lazarus CCROtherpublic2015-05-19 14:17
ReporterLagunov AlekseyAssigned ToDmitry Boyarintsev 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Summary0028130: Error compile richmemo on Linux gtk2
Descriptionrev. 4142


/usr/local/share/lazarus/components/richmemo/./gtk2/gtk2richmemo.pas(1159,30) Error: (5000) Identifier not found "taLeft"
/usr/local/share/lazarus/components/richmemo/./gtk2/gtk2richmemo.pas(1240,8) Warning: (5066) Symbol "UTF8Length" is deprecated: "Use the function in LazUTF8 unit"
/usr/local/share/lazarus/components/richmemo/./gtk2/gtk2richmemo.pas(1243,4) Warning: (5066) Symbol "ConvertUTF8ToUTF16" is deprecated: "Use the function in LazUTF8 unit"
/usr/local/share/lazarus/components/richmemo/./gtk2/gtk2richmemo.pas(1280,38) Hint: (5091) Local variable "txt" of a managed type does not seem to be initialized
gtk2richmemo.pas(1565) Fatal: (10026) There were 1 errors compiling module, stopping
Fatal: (1018) Compilation aborted
Additional Informationdiff file for fix this error:

Index: gtk2/gtk2richmemo.pas
===================================================================
--- gtk2/gtk2richmemo.pas (revision 4142)
+++ gtk2/gtk2richmemo.pas (working copy)
@@ -1156,7 +1156,7 @@
   for i:=0 to AStopList.Count-1 do begin
     pango_tab_array_get_tab(attr^.tabs, i, @al, @loc);
     AStopList.Tabs[i].Offset:=loc*f;
- AStopList.Tabs[i].Align:=taLeft;
+ AStopList.Tabs[i].Align:=tabLeft;
   end;
   gtk_text_attributes_unref(attr);
 end;
TagsNo tags attached.
Widgetset
Attached Files

Activities

Dmitry Boyarintsev

2015-05-19 14:16

developer   ~0083785

please test and close if ok

Dmitry Boyarintsev

2015-05-19 14:16

developer   ~0083786

Last edited: 2015-05-19 14:17

View 2 revisions

why did i add the duplicating issue?

Issue History

Date Modified Username Field Change
2015-05-19 07:28 Lagunov Aleksey New Issue
2015-05-19 14:16 Dmitry Boyarintsev Note Added: 0083785
2015-05-19 14:16 Dmitry Boyarintsev Relationship added duplicate of 0004143
2015-05-19 14:16 Dmitry Boyarintsev Status new => resolved
2015-05-19 14:16 Dmitry Boyarintsev Resolution open => fixed
2015-05-19 14:16 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2015-05-19 14:16 Dmitry Boyarintsev Note Added: 0083786
2015-05-19 14:16 Dmitry Boyarintsev Status resolved => feedback
2015-05-19 14:16 Dmitry Boyarintsev Resolution fixed => reopened
2015-05-19 14:17 Dmitry Boyarintsev Relationship deleted 0004143
2015-05-19 14:17 Dmitry Boyarintsev Note Edited: 0083786 View Revisions
2015-05-19 14:17 Dmitry Boyarintsev Status feedback => closed
2015-05-19 14:17 Dmitry Boyarintsev Resolution reopened => fixed