View Issue Details

IDProjectCategoryView StatusLast Update
0028337LazarusLazDataDesktoppublic2015-06-24 10:21
ReporterPéter GáborAssigned ToMaxim Ganetsky 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version1.6 
Summary0028337: 'New connection ...' menu item
DescriptionClicking on "Connections / New connection..." menu item shows a sub-menu and a dialog with possible connections at the same time... For me this seems to be a design mistake.

The dialog is more descriptive, so I would remove the sub-menu.
TagsNo tags attached.
Fixed in Revision49400, 49413, 49422
LazTarget-
Widgetset
Attached Files

Activities

Maxim Ganetsky

2015-06-21 22:59

developer   ~0084623

IMO the dialog adds little value, so I disabled it. Now only submenu is shown, and this is consistent with Dictionary -> Import menu.

Please test and close if OK.

Péter Gábor

2015-06-22 07:54

reporter   ~0084627

Last edited: 2015-06-22 11:03

View 2 revisions

I found the followings:

"New connection ..." item in the "Connections" menu is not translated (was before)

Ctrl+Alt+N hotkey does not work (dialog is unreachable from this menu)

Right-click in the grid of Connections shows a popup-menu with the "New connection ..." item (it is translated here) and the dialog is shown

Maxim Ganetsky

2015-06-23 00:47

developer   ~0084675

> "New connection ..." item in the "Connections" menu is not translated (was before)

Fixed.

> Ctrl+Alt+N hotkey does not work (dialog is unreachable from this menu)

This shortcut now works, although it is not shown in main menu, because Windows does not seem to allow to have OnClick events (or assigned actions) for main menu items which have sub-items. This Windows behavior is the reason why the dialog was shown when hovering with mouse over this menu item.

Péter Gábor

2015-06-23 10:19

reporter   ~0084678

The third issue is not solved:

Right-click in the grid of Connections (tab) shows a popup-menu with the "New connection ..." item and the mentioned dialog is shown immediately on hovering (as the main menu did before) but the submenu indicated by ">" is not displayed
Also the hotkey is displayed in this popup-menu .

I think that the behaviour and the look of this popup-menu must be the same as of the main menu...

Maxim Ganetsky

2015-06-23 23:43

developer   ~0084689

Heh, it worked on Windows XP correctly for me.

Anyway, fixed. Dialog still should be accessible with Ctrl+Alt+N shortcut.

Péter Gábor

2015-06-24 10:21

reporter   ~0084694

Thanks!

Issue History

Date Modified Username Field Change
2015-06-21 15:43 Péter Gábor New Issue
2015-06-21 22:59 Maxim Ganetsky Fixed in Revision => 49400
2015-06-21 22:59 Maxim Ganetsky LazTarget => -
2015-06-21 22:59 Maxim Ganetsky Note Added: 0084623
2015-06-21 22:59 Maxim Ganetsky Status new => resolved
2015-06-21 22:59 Maxim Ganetsky Fixed in Version => 1.6
2015-06-21 22:59 Maxim Ganetsky Resolution open => fixed
2015-06-21 22:59 Maxim Ganetsky Assigned To => Maxim Ganetsky
2015-06-22 07:54 Péter Gábor Note Added: 0084627
2015-06-22 07:54 Péter Gábor Status resolved => assigned
2015-06-22 07:54 Péter Gábor Resolution fixed => reopened
2015-06-22 11:03 Péter Gábor Note Edited: 0084627 View Revisions
2015-06-23 00:47 Maxim Ganetsky Fixed in Revision 49400 => 49400, 49413
2015-06-23 00:47 Maxim Ganetsky Note Added: 0084675
2015-06-23 00:47 Maxim Ganetsky Status assigned => resolved
2015-06-23 00:47 Maxim Ganetsky Resolution reopened => fixed
2015-06-23 10:19 Péter Gábor Note Added: 0084678
2015-06-23 10:19 Péter Gábor Status resolved => assigned
2015-06-23 10:19 Péter Gábor Resolution fixed => reopened
2015-06-23 23:43 Maxim Ganetsky Fixed in Revision 49400, 49413 => 49400, 49413, 49422
2015-06-23 23:43 Maxim Ganetsky Note Added: 0084689
2015-06-23 23:43 Maxim Ganetsky Status assigned => resolved
2015-06-23 23:43 Maxim Ganetsky Resolution reopened => fixed
2015-06-24 10:21 Péter Gábor Note Added: 0084694
2015-06-24 10:21 Péter Gábor Status resolved => closed