View Issue Details

IDProjectCategoryView StatusLast Update
0028483LazarusLCLpublic2017-06-04 22:08
ReporterLiorAssigned ToMichl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformX64OSWindowsOS Version8.1
Product Version1.4.2Product Build49524 
Target Version1.9 (SVN)Fixed in Version1.9 (SVN) 
Summary0028483: Crash at start up - TControl.InvalidatePreferredSize loop detected
DescriptionAfter debugging the LCL I've noticed that this bug always reproduce if the Application.BidiMode is initialized to bdRightToLeft, probably by values read from the system.
Resulting in ever increasing values on TAutoSizeBox.AlignToRight.

if I manually set Application.BidiMode to bdRightToLeftNoAlign before creating any forms, the bug does not reproduce.
Steps To Reproduce1. Start a new project => file->new->project->application
2. Create panel1 on the form
3. Create panel2 on the form
4. In the object inspector drag panel2 so it'll be the child of panel1
5. Change panel1 autosize property to true
6. Change panel1 ChildSizing.Layout property to cclLeftToRightThenTopToBottom
7. Compile and run the project
TagsNo tags attached.
Fixed in Revisionr55209
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0031966 closedMichl AV: Application.BidiMode bdRightToLeft and Panel1.ChildSizing.Layout cclTopToBottomThenLeftToRight 

Activities

Bart Broersma

2017-02-18 22:45

developer   ~0098302

Is this issue still present?
If so, please attach a sample project (sources only) demonstrating the issue.

Bart Broersma

2017-05-27 00:03

developer   ~0100715

No feedback.

Lior

2017-05-31 15:00

reporter   ~0100746

Last edited: 2017-05-31 15:01

View 2 revisions

Still occurs in 1.6.4,
I've attached a sample project demonstrating the issue.

Lior

2017-05-31 15:00

reporter  

Project1.7z (60,574 bytes)

Bart Broersma

2017-05-31 21:22

developer   ~0100759

Can you please test with 1.8RC1 or trunk?

Lior

2017-06-01 11:41

reporter   ~0100771

Happens also in 1.8.0RC1, exactly the same.

Bart Broersma

2017-06-01 20:08

developer   ~0100776

Thanks for reporting back.

Michl

2017-06-04 16:31

developer   ~0100856

Last edited: 2017-06-04 16:31

View 2 revisions

Fixed in trunk revision 55209. Please test.

The last days, I tested a lot of cases and it seems to work without side effects, but it needs more testing in the wild, so it shouldn't be merged to fixes branch.

Lior

2017-06-04 21:38

reporter   ~0100866

Here is the original change:
https://github.com/graemeg/lazarus/commit/f0c35a35282c2c32d2374e42cbadfe82d3c80a97

Are you certain it won't compromise right alignment when using RTL languages ?

Michl

2017-06-04 22:08

developer   ~0100868

> Are you certain it won't compromise right alignment when using RTL languages ?

I have tested the issue for imho all posibilities (this is only a problem of layout - positions of controls) but of course, I'm not a native user of a RTL layout. Thatswhile I commented the code, don't deleted it, don't merge it to Lazarus 1.8 and wait for maybe resulting problems. If you see any, please report!

Issue History

Date Modified Username Field Change
2015-08-07 00:22 Lior New Issue
2017-02-18 22:45 Bart Broersma LazTarget => -
2017-02-18 22:45 Bart Broersma Note Added: 0098302
2017-02-18 22:45 Bart Broersma Status new => feedback
2017-05-27 00:03 Bart Broersma Note Added: 0100715
2017-05-27 00:03 Bart Broersma Status feedback => resolved
2017-05-27 00:03 Bart Broersma Resolution open => unable to reproduce
2017-05-27 00:03 Bart Broersma Assigned To => Bart Broersma
2017-05-31 15:00 Lior Note Added: 0100746
2017-05-31 15:00 Lior Status resolved => assigned
2017-05-31 15:00 Lior Resolution unable to reproduce => reopened
2017-05-31 15:00 Lior File Added: Project1.7z
2017-05-31 15:01 Lior Note Edited: 0100746 View Revisions
2017-05-31 21:22 Bart Broersma Note Added: 0100759
2017-05-31 21:22 Bart Broersma Status assigned => feedback
2017-06-01 11:41 Lior Note Added: 0100771
2017-06-01 11:41 Lior Status feedback => assigned
2017-06-01 20:08 Bart Broersma Note Added: 0100776
2017-06-01 20:08 Bart Broersma Assigned To Bart Broersma =>
2017-06-01 20:08 Bart Broersma Status assigned => acknowledged
2017-06-04 15:41 Michl Assigned To => Michl
2017-06-04 15:41 Michl Status acknowledged => assigned
2017-06-04 16:31 Michl Fixed in Revision => r55209
2017-06-04 16:31 Michl Note Added: 0100856
2017-06-04 16:31 Michl Status assigned => resolved
2017-06-04 16:31 Michl Fixed in Version => 1.9 (SVN)
2017-06-04 16:31 Michl Resolution reopened => fixed
2017-06-04 16:31 Michl Target Version => 1.9 (SVN)
2017-06-04 16:31 Michl Note Edited: 0100856 View Revisions
2017-06-04 16:40 Michl Relationship added related to 0031966
2017-06-04 21:38 Lior Note Added: 0100866
2017-06-04 22:08 Michl Note Added: 0100868