View Issue Details

IDProjectCategoryView StatusLast Update
0028569Lazarus-public2015-09-22 12:40
ReporterTorsten Bonde ChristiansenAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSLinuxOS VersionArch
Product Version1.5 (SVN)Product Buildr49706 
Target Version1.4.4Fixed in Version1.4.4 
Summary0028569: fpc 3.0.0 RC1 causes Lazarus to give an "Abstract method called" on form read/write
DescriptionThe following error occurs when compiling an empty project with the FPC 3.0.0 RC1 compiler.

Unable to stream Form1:TForm1.
Abstract method called

This is due to wrong {$IF FPC_FULLVERSION ...} statement in lresources.pp and possibly laz_xmlstreaming.pas

A zip coatining patches for both files are attached.
TagsNo tags attached.
Fixed in Revision
LazTarget1.4.4
Widgetset
Attached Files

Relationships

duplicate of 0027817 closedJuha Manninen Reading and writing XML crashes 
duplicate of 0027754 closedJuha Manninen after this revision, on lazarus I get "Abstract method called" 

Activities

Torsten Bonde Christiansen

2015-08-26 11:30

reporter  

fpc_fullversion.patch.zip (1,255 bytes)

Bart Broersma

2015-08-26 11:41

developer   ~0085537

Thanks for reporting.
Fixed in r49711, r48689 and r49712.

Bart Broersma

2015-08-26 11:42

developer   ~0085538

Please close if OK.

Torsten Bonde Christiansen

2015-09-22 12:40

reporter   ~0086031

Fixed

Issue History

Date Modified Username Field Change
2015-08-26 11:30 Torsten Bonde Christiansen New Issue
2015-08-26 11:30 Torsten Bonde Christiansen File Added: fpc_fullversion.patch.zip
2015-08-26 11:38 Bart Broersma Relationship added duplicate of 0027817
2015-08-26 11:38 Bart Broersma Relationship added duplicate of 0028546
2015-08-26 11:40 Bart Broersma Relationship deleted 0028546
2015-08-26 11:40 Bart Broersma Relationship added duplicate of 0027754
2015-08-26 11:41 Bart Broersma Note Added: 0085537
2015-08-26 11:42 Bart Broersma LazTarget => 1.4.4
2015-08-26 11:42 Bart Broersma Note Added: 0085538
2015-08-26 11:42 Bart Broersma Status new => resolved
2015-08-26 11:42 Bart Broersma Fixed in Version => 1.4.4
2015-08-26 11:42 Bart Broersma Resolution open => fixed
2015-08-26 11:42 Bart Broersma Assigned To => Bart Broersma
2015-08-26 11:42 Bart Broersma Target Version => 1.4.4
2015-09-22 12:40 Torsten Bonde Christiansen Note Added: 0086031
2015-09-22 12:40 Torsten Bonde Christiansen Status resolved => closed