View Issue Details

IDProjectCategoryView StatusLast Update
0028654LazarusLCLpublic2018-06-02 07:45
ReporterTBug Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWin32OSWindows 
Product Version1.4.2 
Summary0028654: Setting Contraints-Value has no effect
DescriptionSetting Contraints.MaxHeight to a value smaller then Height dosn't set the Height of the Component to the Contraints.MaxHeight.

Setting Contraints.MaxWidth to a value smaller then Width dosn't set the Width of the Component to the Contraints.MaxWidth.

Setting Contraints.MinHeight to a value higher then Height dosn't set the Height of the Component to the Contraints.MinHeight.

Setting Contraints.MinWidth to a value higherthen Width dosn't set the Width of the Component to the Contraints.MinWidth.

The issue appears at design- and runtime.
Steps To ReproduceCreate a new application and put a TMemo on it.

Use OI to set e.g. the Contraints.MaxHeight to 20.
The TMemo doesn't decrease it's Height to the MaxHeight-Value.

Same behaviour while setting any Constraints-Value during Runtime by:

Memo1.Height := 200;
Memo1.Constaints.MaxHeight := 100;

The Memo1 still has a height of 200.
TagsNo tags attached.
Fixed in Revisionr50942, r56946, r56947, r57082
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0033814 closedOndrej Pokorny After revision 56947 sometimes ObjectInspector.PropertyGrid shows editor on wrong place 
related to 0030005 resolvedOndrej Pokorny Fix to Mantis 28654 in svn 50942 prevents Width/Height being set to ClientWidth/ClientHeight in TControl.Loaded 
related to 0033575 closedOndrej Pokorny Calling procedurelist on 125% dpi display crashes with "InvalidatePreferredSize loop detected" 

Activities

Juha Manninen

2015-09-10 16:37

developer   ~0085841

This should be relatively easy to fix. Can you provide a patch please.

Juha Manninen

2015-12-19 16:35

developer   ~0088085

Fixed, please test.

Ondrej Pokorny

2018-01-04 07:29

developer   ~0105309

Juha, I reverted your change since it wasn't good. Please retest.

Issue History

Date Modified Username Field Change
2015-09-10 15:39 TBug New Issue
2015-09-10 16:37 Juha Manninen Note Added: 0085841
2015-12-17 16:05 Juha Manninen Assigned To => Juha Manninen
2015-12-17 16:05 Juha Manninen Status new => assigned
2015-12-19 16:35 Juha Manninen Fixed in Revision => r50942
2015-12-19 16:35 Juha Manninen LazTarget => -
2015-12-19 16:35 Juha Manninen Note Added: 0088085
2015-12-19 16:35 Juha Manninen Status assigned => resolved
2015-12-19 16:35 Juha Manninen Resolution open => fixed
2016-03-23 18:04 Juha Manninen Relationship added related to 0029884
2016-03-23 18:09 Juha Manninen Relationship deleted related to 0029884
2017-04-11 10:12 Ondrej Pokorny Relationship added related to 0030005
2018-01-04 06:23 Ondrej Pokorny Assigned To Juha Manninen => Ondrej Pokorny
2018-01-04 06:23 Ondrej Pokorny Status resolved => assigned
2018-01-04 06:23 Ondrej Pokorny Resolution fixed => reopened
2018-01-04 07:29 Ondrej Pokorny Fixed in Revision r50942 => r50942, r56946, r56947
2018-01-04 07:29 Ondrej Pokorny Note Added: 0105309
2018-01-04 07:29 Ondrej Pokorny Status assigned => resolved
2018-01-04 07:29 Ondrej Pokorny Resolution reopened => fixed
2018-01-14 12:49 Ondrej Pokorny Fixed in Revision r50942, r56946, r56947 => r50942, r56946, r56947, r57082
2018-04-19 14:25 Ondrej Pokorny Relationship added related to 0033575
2018-06-02 07:45 Ondrej Pokorny Relationship added related to 0033814