View Issue Details

IDProjectCategoryView StatusLast Update
0028661FPCCompilerpublic2015-10-10 11:38
ReporterMark Morgan LloydAssigned ToJonas Maebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformx86OSLinuxOS VersionDebian "Jessie"
Product Version3.1.1Product Build 
Target VersionFixed in Version 
Summary0028661: In 3.0.0 rc1 and trunk, spurious blank lines when compiling
DescriptionCompiling a trivial program outputs a dozen or so blank lines to the controlling shell session.
Steps To Reproduce~$ fpc sample.pas
Free Pascal Compiler version 3.1.1 [2015/09/11] for i386
Copyright (c) 1993-2015 by Florian Klaempfl and others
Target OS: Linux for i386
Compiling sample.pas
Linking sample














/usr/bin/ld: warning: link.res contains output sections; did you forget -T?
24 lines compiled, 0.4 sec
~$
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0027988 resolvedJonas Maebe Variable length line break during the phase of Linkage 

Activities

Cyrax

2015-09-11 17:49

reporter   ~0085855

I recall this is a bug in the ld linker. Newer versions of binutils(?)/ld have this fixed up.

Mark Morgan Lloyd

2015-09-11 23:00

reporter   ~0085857

I see it only affecting recent versions of FPC, running on the same system (i.e. with the same binutils etc. versions).

lifepower

2015-09-12 17:40

reporter   ~0085864

This is duplicate of 28414 and 27988. I still see this issue in up-to-date version of Ubuntu 15.04 x64 and latest trunk. On Linux Mint 17.2 x64, however, this doesn't seem occur.

Anton Kavalenka

2015-09-12 20:29

reporter   ~0085865

Last edited: 2015-09-12 20:42

View 2 revisions

IMO FPC feeds LD with linker script via stdin.

Linker script is generated by FPC with 0x0A line endings.

LD eats some of them and some of them passes through.

000002D0 63 72 74 65 │ 6E 64 2E 6F │ 22 20 6E 6F │ 74 20 66 6F │ 75 6E 64 2C │ 20 74 68 69 │ 73 20 77 69 │ 6C 6C 20 70 │ 72 6F 62 61 crtend.o" not found, this will proba
000002F4 62 6C 79 20 │ 63 61 75 73 │ 65 20 61 20 │ 6C 69 6E 6B │ 69 6E 67 20 │ 66 61 69 6C │ 75 72 65 0A │ 57 61 72 6E │ 69 6E 67 3A bly cause a linking failure.Warning:
00000318 20 22 63 72 │ 74 6E 2E 6F │ 22 20 6E 6F │ 74 20 66 6F │ 75 6E 64 2C │ 20 74 68 69 │ 73 20 77 69 │ 6C 6C 20 70 │ 72 6F 62 61 "crtn.o" not found, this will proba
0000033C 62 6C 79 20 │ 63 61 75 73 │ 65 20 61 20 │ 6C 69 6E 6B │ 69 6E 67 20 │ 66 61 69 6C │ 75 72 65 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A bly cause a linking failure.........
00000360 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A ....................................
00000384 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 0A 0A │ 0A 0A 35 39 ..................................59
000003A8 20 6C 69 6E │ 65 73 20 63 │ 6F 6D 70 69 │ 6C 65 64 2C │ 20 35 2E 30 │ 20 73 65 63 │ 0A 34 20 77 │ 61 72 6E 69 │ 6E 67 28 73 lines compiled, 5.0 sec.4 warning(s

Anton Kavalenka

2015-09-12 21:11

reporter   ~0085866

number of LF equal to number of .o in INPUT() stanzas

Issue History

Date Modified Username Field Change
2015-09-11 12:34 Mark Morgan Lloyd New Issue
2015-09-11 17:49 Cyrax Note Added: 0085855
2015-09-11 23:00 Mark Morgan Lloyd Note Added: 0085857
2015-09-12 17:40 lifepower Note Added: 0085864
2015-09-12 20:29 Anton Kavalenka Note Added: 0085865
2015-09-12 20:42 Anton Kavalenka Note Edited: 0085865 View Revisions
2015-09-12 21:11 Anton Kavalenka Note Added: 0085866
2015-09-13 00:33 Jonas Maebe Relationship added duplicate of 0027988
2015-09-13 00:33 Jonas Maebe Status new => resolved
2015-09-13 00:33 Jonas Maebe Resolution open => duplicate
2015-09-13 00:33 Jonas Maebe Assigned To => Jonas Maebe
2015-10-10 11:38 Mark Morgan Lloyd Status resolved => closed