View Issue Details

IDProjectCategoryView StatusLast Update
0028733LazarusConverterpublic2015-09-27 15:11
ReporterUdo SchmalAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformallOSallOS Versionall
Product Version1.5 (SVN)Product BuildRevision 49820 
Target Version1.6Fixed in Version1.6 
Summary0028733: SynExportHtml exports no CodeStart with Option heoFragmentOnly but a CodeEnd
Descriptioncomponents/synedit/synexporthtml.pas Line 402:
    if (heoWinClipHeader in fOptions) then
      DocHeader := DocHeader + StartFragmentComment + CodeStart
    else
      DocHeader := CodeStart;

Also it would be nice to change the Code in the next Lines to get cleaner HTML:
  if fFontSize <> fsDefault then
    sFontSize := Format('size="%d"', [1 + Ord(fFontSize)])
TagsNo tags attached.
Fixed in Revisionr49874
LazTarget1.6
Widgetset
Attached Files

Activities

Bart Broersma

2015-09-27 11:26

developer   ~0086102

Probably because of my rework.

Bart Broersma

2015-09-27 11:39

developer   ~0086103

Please test and close if OK.

Open a new feature request for the second part of this bug.

Issue History

Date Modified Username Field Change
2015-09-26 16:38 Udo Schmal New Issue
2015-09-26 16:38 Udo Schmal Status new => assigned
2015-09-26 16:38 Udo Schmal Assigned To => Juha Manninen
2015-09-27 11:26 Bart Broersma Assigned To Juha Manninen => Bart Broersma
2015-09-27 11:26 Bart Broersma Note Added: 0086102
2015-09-27 11:39 Bart Broersma Fixed in Revision => r49874
2015-09-27 11:39 Bart Broersma LazTarget => 1.6
2015-09-27 11:39 Bart Broersma Note Added: 0086103
2015-09-27 11:39 Bart Broersma Status assigned => resolved
2015-09-27 11:39 Bart Broersma Fixed in Version => 1.6
2015-09-27 11:39 Bart Broersma Resolution open => fixed
2015-09-27 11:39 Bart Broersma Target Version => 1.6
2015-09-27 15:11 Udo Schmal Status resolved => closed