View Issue Details

IDProjectCategoryView StatusLast Update
0028748FPCCompilerpublic2018-05-21 09:05
ReporterMaciej IzakAssigned ToYuriy Sydorov 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformARMOSAndroidOS Version
Product Version3.1.1Product Build 
Target VersionFixed in Version3.0.2 
Summary0028748: Adding Double to Currency - wrong result
DescriptionSomething is wrong between conversion Double <=> Currency for ARM Android platform:

var
  x: Double;
  y: Currency;
begin
  x := 0.1;
  y := 0.1;
  WriteLn(CurrToStr(x + y)); // will print 1000.1 instead of 0.2
TagsNo tags attached.
Fixed in Revision32054
FPCOldBugId
FPCTarget
Attached Files

Relationships

has duplicate 0030483 resolvedJonas Maebe Real x Currency multiplication is not correct 
has duplicate 0030911 resolvedMichael Van Canneyt Calculations involving type Currency procuce wrong results 
related to 0029760 resolvedLacaK Heavy Error in Firebird-DB with Numeric / Decimal Fields - value is multiplied with 10000 insert and update 
related to 0033758 closedYuriy Sydorov Currency bug on Win64 only 
related to 0033755 closedMichael Van Canneyt Update ODBC header function due to problem on Win64 

Activities

Yuriy Sydorov

2015-10-14 00:33

manager   ~0086543

I've fixed it in r32054. Please test and close the bug.

Issue History

Date Modified Username Field Change
2015-09-29 14:55 Maciej Izak New Issue
2015-10-14 00:33 Yuriy Sydorov Fixed in Revision => 32054
2015-10-14 00:33 Yuriy Sydorov Note Added: 0086543
2015-10-14 00:33 Yuriy Sydorov Status new => resolved
2015-10-14 00:33 Yuriy Sydorov Fixed in Version => 3.1.1
2015-10-14 00:33 Yuriy Sydorov Resolution open => fixed
2015-10-14 00:33 Yuriy Sydorov Assigned To => Yuriy Sydorov
2016-03-10 21:34 LacaK Relationship added related to 0029760
2016-08-21 14:04 LacaK Relationship added related to 0030483
2016-08-29 22:52 Jonas Maebe Relationship replaced has duplicate 0030483
2016-09-22 10:07 Yuriy Sydorov Fixed in Version 3.1.1 => 3.0.2
2016-11-11 13:19 Jonas Maebe Relationship added has duplicate 0030911
2018-05-18 14:58 LacaK Relationship added related to 0033758
2018-05-21 09:05 LacaK Relationship added related to 0033755