View Issue Details

IDProjectCategoryView StatusLast Update
0028752LazarusLCLpublic2015-09-29 21:58
ReporterrbAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindows XPOSOS Version
Product VersionProduct Build 
Target Version1.6Fixed in Version1.5 (SVN) 
Summary0028752: DBGrid AutoAdvance aaNone change the selected cell after editing
DescriptionIn DBgris.AutoAdvance = aaNone shouldn't change the selected cell after editing.

It looks the selection move according on the global Col, Row instead of the Delta Col, Row.
Steps To ReproduceOpen the Demo, press button fill data
- select Col 1, Row 1, edit the cell and press Enter
 - the cursor jump to Col 2, Row 2 even the Grid.AutoAdvance = aaNone
TagsNo tags attached.
Fixed in Revision49897
LazTarget1.6
Widgetset
Attached Files

Activities

rb

2015-09-29 15:16

reporter  

test_dbGrid.zip (130,259 bytes)

Jesus Reyes

2015-09-29 21:58

developer   ~0086170

I moved the bug report to lazarus/lcl, if it's a mistake please report.

In anyway the problem is reproduced in lazarus/lcl so I fixed it, please test.

Issue History

Date Modified Username Field Change
2015-09-29 15:16 rb New Issue
2015-09-29 15:16 rb File Added: test_dbGrid.zip
2015-09-29 21:54 Jesus Reyes Project fpGUI => Lazarus
2015-09-29 21:55 Jesus Reyes LazTarget => -
2015-09-29 21:55 Jesus Reyes Category Widgetset => LCL
2015-09-29 21:55 Jesus Reyes Assigned To => Jesus Reyes
2015-09-29 21:55 Jesus Reyes Status new => assigned
2015-09-29 21:58 Jesus Reyes Fixed in Revision => 49897
2015-09-29 21:58 Jesus Reyes LazTarget - => 1.6
2015-09-29 21:58 Jesus Reyes Note Added: 0086170
2015-09-29 21:58 Jesus Reyes Status assigned => resolved
2015-09-29 21:58 Jesus Reyes Fixed in Version => 1.5 (SVN)
2015-09-29 21:58 Jesus Reyes Resolution open => fixed
2015-09-29 21:58 Jesus Reyes Target Version => 1.6