View Issue Details

IDProjectCategoryView StatusLast Update
0028762FPCRTLpublic2019-12-19 14:41
ReporterCudaText man Assigned ToJonas Maebe  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionduplicate 
Product Version3.0.1 
Summary0028762: TFormatSettings char fields
Description
TFormatSettings has char members:
    ThousandSeparator: Char;
    DecimalSeparator: Char;
    DateSeparator: Char;
    TimeSeparator: Char;
    ListSeparator: Char;
This gives problem: RU locale on Linux has not-one-char specifier for thousandsep, it is some string.
This gives bug in LazIDE: "Code browser" window statusbar shows numbers like "total=14?800/20?900" (IDE keepers don't want to make workaround for this "?")...

Pls, change chr to string?
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0028686 new FormatSettings.ThousandSeparator don't accept multbyte character 

Activities

CudaText man

2015-09-30 20:46

reporter   ~0086190

I talk about http://mantis.freepascal.org/view.php?id=28758

Marco van de Voort

2015-09-30 21:06

manager   ~0086191

Changing it to string would be delphi incompatible. It should be unicodechar.

CudaText man

2015-09-30 21:15

reporter   ~0086192

then maybe separate field (str) near char field? With suffix.

Issue History

Date Modified Username Field Change
2015-09-30 20:45 CudaText man New Issue
2015-09-30 20:46 CudaText man Note Added: 0086190
2015-09-30 21:06 Marco van de Voort Note Added: 0086191
2015-09-30 21:15 CudaText man Note Added: 0086192
2015-10-01 07:46 Jonas Maebe Relationship added duplicate of 0028686
2015-10-01 07:46 Jonas Maebe Status new => resolved
2015-10-01 07:46 Jonas Maebe Resolution open => duplicate
2015-10-01 07:46 Jonas Maebe Assigned To => Jonas Maebe
2019-12-19 14:41 CudaText man Status resolved => closed