View Issue Details

IDProjectCategoryView StatusLast Update
0028770LazarusLazReportpublic2016-07-21 12:28
ReporterEdson LidorioAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows 7OS VersionProfessional
Product Version1.4.2Product BuildTrunk Last 
Target Version1.8Fixed in Version1.7 (SVN) 
Summary0028770: LazReport Designer in Windows does not save the last directory
Description
Hello,

LazReport Designer in Windows does not save the last directory that was opened lrf files.
Using Linux this problem doesn't happen, normally works.
TagsNo tags attached.
Fixed in Revision52708, 52723
LazTarget1.8
Widgetset
Attached Files

Relationships

has duplicate 0029285 resolvedJesus Reyes LazReport not saving the last property 

Activities

Edson Lidorio

2015-10-02 21:20

reporter   ~0086228

In linux when it working in Lazreport Designer and insert an object rectangle memo, and alter some property that memo, for example the Left and press the enter key then is normal procedure to select another memo and altar the same property of the same then it is open the Text Editor of this memo, which would be normal place was out of the selection of this memo.
Already on windows does not occur this problem.

Edson Lidorio

2015-12-22 03:05

reporter   ~0088157

This problem still persists.

Edson Lidorio

2016-04-09 03:12

reporter   ~0091869

This problem still persists.

Jesus Reyes

2016-07-18 00:24

developer   ~0093748

Fixed, please test.

Edson Lidorio

2016-07-18 04:25

reporter   ~0093751

This viewing in OpenDialog the last file and not the last directory.

Jesus Reyes

2016-07-18 07:17

developer   ~0093752

It is doing that in the LAST used directory.

If it doesn't meet your expectatives, please give me a list of steps to follow, what it does and what it does not. This way I will try to meet your requirements.

Also your first note (0086228) doesn't seems to be related to this report, or maybe I got everything wrong. Please clarify,

Edson Lidorio

2016-07-20 04:30

reporter   ~0093772

I'm sending the comments on the image. I think it's easier to understand

Please open the following image to facilitate understanding.

1-Open existing file 1.png
2-Open existing file 2.png
3-linux.png
4-Designer - Untitled.png

On the open issues are:

1-If it's not saving the Lazreport last directory.

2-If it's not Lazreport saving last used in property inspector obeject.
Example: for example:

In the object inspector of Lazreport being selected a Memo1 on property Left to jump to Focus on property Left Memo2 is not preserved it goes to another property.

Edson Lidorio

2016-07-20 04:30

reporter  

Pictures.7z (250,998 bytes)

Jesus Reyes

2016-07-20 08:37

developer   ~0093773

Last edited: 2016-07-20 08:38

View 2 revisions

I'm sorry, I misread the bug report, please try again, and report back closing the report or giving feedback.

I'm sorry again, I'm resolving this report because I think it's now fixed. I think I understand what you say in the note (0086228) and later in the last part of note (0093772) point 2, and I still think the second issue you are reporting is unrelated to this report, I'm not saying the second issue doesn't exist, again is NOT related to this report. Feel free to to submit a report for that one.

And please DON'T add multiple issues in a single bug report.

Edson Lidorio

2016-07-21 02:34

reporter   ~0093787

Problem solved, you can close this issue.

Jesus Reyes

2016-07-21 02:47

developer   ~0093788

In fact it is you as the reporter who has to close this issue :).

Please use the close button. Thanks.

Issue History

Date Modified Username Field Change
2015-10-02 02:09 Edson Lidorio New Issue
2015-10-02 21:20 Edson Lidorio Note Added: 0086228
2015-12-22 03:05 Edson Lidorio Note Added: 0088157
2016-04-09 03:12 Edson Lidorio Note Added: 0091869
2016-04-09 06:52 Jesus Reyes Assigned To => Jesus Reyes
2016-04-09 06:52 Jesus Reyes Status new => assigned
2016-04-09 06:54 Jesus Reyes Relationship added has duplicate 0029285
2016-07-18 00:24 Jesus Reyes Fixed in Revision => 52708
2016-07-18 00:24 Jesus Reyes LazTarget => 1.8
2016-07-18 00:24 Jesus Reyes Note Added: 0093748
2016-07-18 00:24 Jesus Reyes Status assigned => resolved
2016-07-18 00:24 Jesus Reyes Fixed in Version => 1.7 (SVN)
2016-07-18 00:24 Jesus Reyes Resolution open => fixed
2016-07-18 00:24 Jesus Reyes Target Version => 1.8
2016-07-18 04:25 Edson Lidorio Note Added: 0093751
2016-07-18 07:17 Jesus Reyes Note Added: 0093752
2016-07-18 07:22 Jesus Reyes Status resolved => feedback
2016-07-20 04:30 Edson Lidorio Note Added: 0093772
2016-07-20 04:30 Edson Lidorio Status feedback => assigned
2016-07-20 04:30 Edson Lidorio File Added: Pictures.7z
2016-07-20 08:37 Jesus Reyes Fixed in Revision 52708 => 52708, 52723
2016-07-20 08:37 Jesus Reyes Note Added: 0093773
2016-07-20 08:37 Jesus Reyes Status assigned => resolved
2016-07-20 08:38 Jesus Reyes Note Edited: 0093773 View Revisions
2016-07-21 02:34 Edson Lidorio Note Added: 0093787
2016-07-21 02:47 Jesus Reyes Note Added: 0093788
2016-07-21 12:28 Edson Lidorio Status resolved => closed